Help! PowerBook G4 Airport card just disappeared?!

Discussion in 'PowerPC Macs' started by ArtHistoryMajor, Mar 9, 2009.

  1. ArtHistoryMajor macrumors newbie

    Oct 8, 2008
    So I go through the entire day working on my laptop at various public hotspots, using the Internet and connecting okay.

    I get home and I restart my laptop and -- no more connection! The airport symbol disappeared from the toolbar! And when I tried going through Network Connect or attempted to configure the airport card, it says that "no airport hardware detected" x.x

    Is this... the end of my lappy? :O At least, wirelessly? Or has this happened to someone and can be easily resolved?

    (BTW - posting right now thanks to ethernet cables plugged right into router)
  2. iLog.Genius macrumors 601


    Feb 24, 2009
    Toronto, Ontario
    Go to System Profiler (Apple>About This Mac>More Info) and see if it detects the Airport Card. If not then it's hardware related if it is detected software related.

    - reset PRAM and SMC
    - might have to do a Archive and Install
  3. ArtHistoryMajor thread starter macrumors newbie

    Oct 8, 2008
    Yeah, certainly isn't detected.


    Attached Files:

  4. J DILLA macrumors member

    Mar 6, 2009
    i believe i had the same problem on mine once, and i solved it by resetting the PRAM.

    or maybe it was the volume bar that disappeared.... lolz

    anyways, try resetting the PRAM.
  5. colmaclean macrumors 68000


    Jan 6, 2004
    I had a similar problem with mine once, however it was after I'd dropped my PowerBook.

    The Airport card had become partially unconnected from its socket. Simply pushing the card back in sorted everything. :)

Share This Page