Help! PowerMac G4 does not start!

Discussion in 'PowerPC Macs' started by dadada2000, Dec 17, 2006.

  1. dadada2000 macrumors newbie

    Sep 25, 2004
    Hi, I just got a G4 466Mhz powermac
    I had it running for 2 days and then just opened it to take out a DVD Burner that was in it, and replace it with just a DVD drive.
    Now when I try to turn it on, the glowing power light comes on for about 1/2 a second then nothing else happens. :mad:
    I opened it back up and then tried to start it with the case open,
    The fan below the power supply turns for about 1 second then stops. I also noted that a small red led near the mem modules was turns of for a second.

    I tried resetting the PMU. But that didn’t seem to help at all…
    Is it the power supply?

  2. product26 macrumors 6502a


    May 30, 2005
    check all your connections, try to undo what you did (put the old optical drive back in, or simply unhook the new one)

    work your way back to how it was before the problem.

    also make sure that the memory is seated properly.
  3. spinne1 macrumors 6502a


    Mar 12, 2005
    Hermitage, TN USA (near Nashville)
    I've had my machine do that when hardware was changed. It seemed I was able to get it working by hitting the reset button on the motherboard and then by holding the power button in on the front of the computer. I don't really know if you can "hold" the front button but it worked for me and so there you go. I can't remember but there may be more than one button on the motherboard. If so, you need to hit the right one.

    Some links that might help:
  4. Cuckoo macrumors 6502

    May 2, 2003
    The Netherlands - Utrecht
    What could be the issue is a master/slave/cable select setting.

    Fastest way of find out, remove the power cable from the DVD drive and try to boot it.

    If the PM starts up, then it might be the above setting. And try and remove the DVD drive, check it's setting and make it equal to the old drive. If you can't find out what the old drives' setting was. Then you would have to check the other device on the IDE cable. And chose the opposite option. Unless the other device is Cable select, then the DVD has to be Cable select as well.

    does this help you?? or is it an other option?
  5. dadada2000 thread starter macrumors newbie

    Sep 25, 2004
    Thank you all for the replies. I have unplugged the DVD drive and tried to start, but nothing happens. I have also took out the RAM and reseeded it, still nothing, no beep/ bog, no startup.. I’ll have to try what spinne1 said:
    “I was able to get it working by hitting the reset button on the motherboard and then by holding the power button in on the front of the computer.”
  6. Sdashiki macrumors 68040


    Aug 11, 2005
    Behind the lens
    a long shot, but it could be the logicboard got fried.

    my MDD G4 had the same symptoms, power button held causes it to glow but not keep the machine on (like keeping the key turned to start in a car but it wont turn over).

    i didnt replace anything, just restarted and it died.

    heres hoping its NOT that!
  7. Cuckoo macrumors 6502

    May 2, 2003
    The Netherlands - Utrecht
    Well, what i would do is search for an apple service manual. There is explained what signals (like the red motherboard light) mean.

    I used to use but apple have forced them to remove the manuals... just google for "apple service manual powermac" (without the quotes) and you'd be allright
  8. dadada2000 thread starter macrumors newbie

    Sep 25, 2004
    it was on...

    Well, I’m not sure what I did last night, but I had the case open, unplugged, took out the battery and hit the reset button on the mother board, and I also hit the buttons on the front of the case… at first nothing happened, I then put the battery back in, pushed the buttons some more and then it started! Man was I happy:D … so I used it for about 20min, reset the time, and made sure everything was working, DVD drive was working fine. I do a Shutdown so that I can close the case, next I close the case and then try to start it and NOTHING! :mad: Same thing is happing, push the button the front of the case, it glows for about ½ sec then dims out, oh the profanity that was heard.. I tried to do everything I did before but can’t get it to work, so now I’m thinking maybe it’s a wire/ connection issue? I still can’t find a manual for a Powermac G4 dul 466 Mhz.

    Anyone know or experience this problem?

    The thing is I’m not even keeping this for my self (I kinda wish I could keep it), I am fixing it for my brother so that he can give it to his mother-in-law.
  9. spinne1 macrumors 6502a


    Mar 12, 2005
    Hermitage, TN USA (near Nashville)
    No, but another thing to try is to carefully inspect the wiring coming from the power supply behind the DVD drive. It is possible a wire is being pinched and partially developing an open or short (although in the case of a complete short to ground it would likely kill the power supply). Also, the RAM could be finicky. Try different modules in different positions while also doing the other tricks. Try leaving the computer off for a few hours then coming back and trying again. Try booting into Open Firmware and resetting it. Try resetting the PRAM. Try taking the main processor and all PCI cards out and cleaning the computer out and reseating all cards and the processor and trying again. Try a different power source (are you using the third leg of a 6-plug to 6-plug to 6-plug extension to power the computer?). Get a voltmeter and check the voltage of the main motherboard connector with it disconnected and the black probe touching any black wire in the motherboard connector harness and the red touching the white wire in pin #22 (the end and the only white wire). When the power supply is plugged in this should read 28V (without the computer being powered on). If it reads less than 12V your computer will NOT boot up. If it reads less than 12V you need a new power supply.

    Some ideas.
  10. TheAnswer macrumors 68030


    Jan 25, 2002
    Orange County, CA
    Definitely check the drive bay wires and make sure the corners of the case aren't crimping them also.

    Good luck.
  11. chipchen macrumors 6502

    Oct 30, 2002
  12. smitty078 macrumors member

    Sep 2, 2004
    Try replacing the PRAM battery (you seem to know what this is since you mention removing it) with a new one. You should be able to find a replacement at radio shack, just bring in the old one. I bet it works with a new battery.
  13. dpaanlka macrumors 601


    Nov 16, 2004
  14. chipchen macrumors 6502

    Oct 30, 2002
    Sounds good... but many people run their computers with a dead battery. They just have the headache of always having to reset the date and time.
  15. smitty078 macrumors member

    Sep 2, 2004
    I've had more than one mac that has refused to boot with a dead battery. Replacing the battery restored them to normal function. One of these macs was a powermac 6100 (real old one) and this machine would not boot at all, it was completely dead. I forget what caused me to try replacing the battery, but it was replacing the battery that fixed it. The 2nd mac I've had with this behavior is a powermac g4 quicksilver (dual 800mhz). The G4 would boot intermittently. Sometimes it would boot fine, other times it would appear completely dead. Usually when it was completely dead hitting the power button gave varrying degrees of response. Sometimes the light would come on but go off right away, other times the fan would whirr and then it would shut off. I eventually decided to replace the PRAM battery, and as soon as I did all of the problems disappeared. I recommended replacing the battery because of these two first hand experiences. I'm sure some models (or even the same models) behave differently and are able to boot just fine with a dead battery, it's just that I have personally seen 2 with problems similar to the original poster's problem that just needed a new battery.
  16. motoxpress macrumors 6502

    Mar 8, 2006
    My son has a Powermac G4 400 that boots intermittently but is fine when it's up. Does this sound like a PRAM battery issue? Where is the battery on the MB?

  17. spinne1 macrumors 6502a


    Mar 12, 2005
    Hermitage, TN USA (near Nashville)
    Look at the motherboard. You will immediately know where the battery is.
  18. Sam0r macrumors regular

    Jun 15, 2005
    Birmingham, UK
    I had this problem aswell, although it wasn't the battery.

    I was trying to change the fan speed in my mac using resistors on the wires connecting the power supply to the fans, but I grounded something, and I got the exact same response from the system as you are having.

    Even after I'd fixed the grounding problem, It still wouldn't boot.

    I reset the PRAM and still nothing.

    So, I disconnected the power cable and left it over night.

    Plugged it back in when I got up, and it worked fine.

    Might be worth a try.
  19. GitTom macrumors newbie

    Jan 8, 2007
    Resetting PRAM worked

    My Symptoms were:
    Power button would light up while holding, but go off a second after letting go.
    Fans, hard drives, and the red LED on the motherboard would not go on at all.

    Powermac G4 dual 1GHz quicksilver

    I pressed the little button beside the battery on the motherboard, and then the computer would start up as normal.

    Just removing the battery didn't work.

    The computer was unplugged over the holidays, and the battery is probably very weak and the PRAM memory ran out of power while the computer was unplugged.

    When I finally got round checking the voltage of the battery, it was up to full 3.6V again, but apparently the PRAM was already messed up.

    I hope this will help somebody.

  20. waremaster macrumors 6502

    Aug 27, 2006
    This is your answer!

Share This Page