Help: PPC Will Not Enter Classic Mode or Boot From CD

Discussion in 'PowerPC Macs' started by BWCDoc, Jul 6, 2011.

  1. BWCDoc macrumors newbie

    Jul 6, 2011
    I have a Power PC (PPC) G4 Mirror Drive Door (MDD). I got it because the power supply on my old iMac G3 failed. I installed the G3's 6 GB hard disk drive (HDD) running OS 8.6 in the new PPC that has an 80 GB HDD now running OS 10.5.8 (Leopard).

    Well, I finally filled up both HDD’s so I bought a Western Digital 2TB USB external HDD. Since it is a USB 2 device and my computer has USB 1.1, I also bought a Belkins USB 2.0 5-port PCI card. I installed the card, mounted the drive, formatted it (journaled HFS+) and used Disk Utility to copy all of the info from the 80 GB drive onto it. I did not erase any of the 80 GB drive. Everything worked fine.

    Through the years I have upgraded all of my software to OS 10 versions except for Quicken. Every new version of Quicken (including the latest) has had bad-bad-bad reviews so I have never upgraded it. Since I use it a LOT, I have always had to reboot in Classic mode to run it.

    Now to my problem: I can no longer boot in Classic mode. OS 9 has disappeared but OS 8.6 still shows up as a Start Up Disk in System Preferences. With restart, the folder icon with a question mark that immediately changes to the folder icon with the face profile appears twice and thent he big Apple logo appears and OS X boots.

    I tried moving Leopard’s System Files into another folder so that the computer would be forced to use 8.6. Bad idea. Would not boot at all. I used my OS 10.5 CD to run Disk Utility Repair and no problem was found. I pulled out my OS 8.1 CD and tried to restart by pressing the C key at start up. Would not work. I tried the same thing using my OS 10.5 CD and it would not work either. I tried to reinstall OS 8.1 from the CD but I got a message that said that the computer can’t open the application “Mac OS Install” because the Classic environment is no longer supported. I had to spend hours re-installing 10.5 and downloading the updates to 10.5.8.

    I have tried to boot in 8.6 from System Preferences, by holding down the C-key at start up and by holding down the Option key at start up. None worked.

    I noticed that many of the files, including the System file, in the OS 8.6 System Folder were described as Unix Executable Files. Can that be right?

    How can I get 8.1 to launch or, at least, get the CD to boot so that I can reinstall it?

    Thanks for slogging through this wordy question and any help that you can give me.
  2. chrismacguy macrumors 68000

    Feb 13, 2009
    United Kingdom
    Your PowerMac G4 MDD cannot boot any version of the Classic Mac OS except a highly-customized version of Mac OS 9.2.2 that it shipped with (This is not retail 9.2.2, but a newer build specifically for late-model G4s). Any version prior to this will never work on your G4 MDD (Even another version of 9, but definitely not 8) and your G4 cannot boot from those CDs. Your only option is to get Mac OS X working, and then find a copy of Mac OS 9 for the classic environment inside Mac OS X 10.4 and below, or to find the original system install Discs for your MDD, and reinstall Mac OS 9 from those CDs.

Share This Page