Help! Printing wirelessly from macbook to windows xp..

Discussion in 'Mac Basics and Help' started by FFB11, Jan 2, 2011.

  1. FFB11 macrumors newbie

    Joined:
    Jan 2, 2011
    #1
    Thanks in advance for any help, I've been a long time reader but finally made a user name!

    My problem:

    I am trying to print wirelessly from my Macbook Pro to my Desktop running windows XP. The desktop is wired directly to the router and the printer, the macbook is wireless.

    I can enabled sharing on the printer on the desktop, and added the printer to my macbook. My problem is when i try to print It send's a signal to my desktop, the HP "ink level" pop up comes up, the printer shows spooling in the details then it disappears and never prints. I know I am close but have been messing with this for 2 days and I cant figure it out. Please tell me what i am doing wrong! I was reading something about going to Network-advanced-WINS but i am not sure that is the problem...

    Thanks for the help!

    Barry
     
  2. velocityg4 macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #2
    If this is a USB only HP printer. Then the HP drivers likely only work via a direct USB connection (sharing between two macs work).

    You will need to install third party drivers that allow network printing. When I had to do this I used HPIJS drivers to run an Officejet 6110 connected to an XP computer. Be sure to read the linked page and install all three parts HPIJS, Foomatic-RIP and Ghostscript.

    If that does not have the correct driver you can try Gutenprint. These were problematic on my printer model so I used HPIJS.

    I will note however that though the drivers are functional for printing the options in the print dialogue will differ from HP's. Twain (scanner) was not supported over the network and likely still is still not, though as I recall there was a similar project to HPIJS for twain. I'm not sure if Colorsync is but I would assume not.
     
  3. MikeRoger macrumors newbie

    Joined:
    Jan 4, 2011
    #3
    Well if i am not wrong there is some issue with your printer settings.These may may not be set properly.I have not exactly worked like this but i have used these set up many times.
    If issue is not yest solved you can install new drivers, this will solve the issue.
     

Share This Page