HELP! Problem detecting my Gamepad

Discussion in 'Mac and PC Games' started by Sinisterniik, Feb 11, 2011.

  1. Sinisterniik macrumors newbie

    Joined:
    Feb 11, 2011
    #1
    This is probably more of an OS X hardware issue, but I'm posting here because it is also game-related and I suspect someone else has had the same issue.

    I'm running SNES9x as well as a couple of other emulators on my MacBook Pro (OS X 10.5.8, Intel Processor). I used to have a Logitech gamepad that worked great, but it broke a while back. Recently, I decided to try a PS3 Dualshock 3 controller (I like the feel and design of PS controllers).

    When I first plugged it in, it seemed unresponsive, but after hitting the gamepad's central "power" button a couple times it seemed to work. I went into the configuration menu and synced the game's commands to my gamepad. It worked great!

    Then, on day 2, it decided to stop working. The gamepad doesn't seem to be detected (whether bluetooth is on or not). I've tried unplugging and replugging it at various times (before restarting/before shutting down/after shutting down, but before restarting/after restarting/after shutting down and restarting), but nothing seems to work.

    Then, I decided to look at my System Profiler. It reads as though a device is detected in my USB port (USB Bus > BRCM2046 Hub > Bluetooth USB Host Controller). However, nothing seems to change when I unplug/replug my USB device. I've tried restarting, but it's still there (I'm assuming this is the gamepad since I'm not currently using an external keyboard/mouse/etc.).

    One of my other emulators, Genesis Plus, is able to detect devices and then configure them. It worked fine as well. Now however, the program _tells me_ that it can't detect any device -not even the one that the System Profiler recognizes.

    So here's my hypothesis: My OS originally detected the USB gamepad but kept the system cache when I ejected it. Now, it can't detect the gamepad because there's already an identical cache file (it thinks the device is still attached). I suspect that if I can either A) Force eject the USB device in the System Profiler or B) Delete the system cache file that I should be able to use my gamepad again.

    Problem is, nothing else is capable of detecting the gamepad -not Disk Utility, not USB Overdrive, nothing! Only the System Profiler recognizes the gamepad as being attached to the USB port.

    PLEASE HELP! I don't want to be stuck with a useless gamepad and a tied up USB port.
     
  2. Sinisterniik thread starter macrumors newbie

    Joined:
    Feb 11, 2011
    #2
    A clarification on this. My roommate's Mac also reads this way. So either I just don't know what the "Bluetooth USB Host Controller" is or else both of our Macs are picking it up via bluetooth device (although my Bluetooth File Exchange doesn't currently recognize my Dualshock 3 as a device).
     
  3. Sinisterniik thread starter macrumors newbie

    Joined:
    Feb 11, 2011
    #3
    Fixed!

    I found the problem!

    It was much simpler than I thought: a connection problem.

    I was troubleshooting with the controller when the 5-pin adapter broke off (BROKE OFF!). I returned the chord, plugged it in and POOF it started working.

    If I encounter anymore problems, I'll reply to this thread, but for now chalk one up for mechanical error.
     

Share This Page