Help: Problem with TiBook, loads to grey screen

Discussion in 'PowerPC Macs' started by Amber, Mar 25, 2006.

  1. Amber macrumors regular

    Mar 23, 2006
    I purchased a Ti Powerbook (500mhz) off eBay a few days ago. It has a crack in the CD Drive area yet loads and plays CDs ok.

    First time I turned it on it went to a grey screen, like black and white pixels together. After turning it off and on a few times it loaded in OS X 10.4. I played around with it for a while and noticed none of the programs worked (well most anyway) I fixed the permissions in Disk Utility (I think, I'm a switcher) and everything worked fine. I could play a DVD, use widgets etc. I couldn't seem to use it on an uneven surface or move it while it was on or it would freeze. I figured this might be a lose cable or something. I read something about an orange cable causing this?

    Anyway, the following morning I turned it on and it went to the grey screen. Turned it on and off again and it went to a screen with a folder with question mark then it goes to a face (or two faces maybe?) I've tried loading OS 9 disk into it and holding down C and it goes to the same screen. If I boot it from the hardware test CD it works and says everything is fine in the test. Something strange though it when it tests the Video Ram (I think) the screen flashes strange colours. Is this normal?

    I didn't get the OS X CD with it so I'm probably going to purchase this when I get chance and the money.

    Everytime I turn it on it goes to the same screen with the folder/question mark/face(s) I hear the apple start up sound.

    The previous owner said the laptop would freeze a lot and sometimes just not turn on. When I had it working after using disk utlity it worked perfect as long as I didn't move it and I was really happy with it.

    Any ideas? Any help is appreciated

    Thanks in advance.

    edit: Something else I've tried, if I hold down the option key (I read you can chose the OS before starting) I get a screen with a arrow button pointing to the right on the right and a return (circle arrow) button on the left. If I click the circle arrow I get a watch cursor then nothing happens and it goes back to a pointer. The right arrow doesn't do anything.
  2. California macrumors 68040


    Aug 21, 2004
    Make sure the hard disk is highlighted under start up disk. I forget how to get there. Is this the original 10 or 20 gig drive? If so, it could be failing, too.

Share This Page