help problems on macbook pro

Discussion in 'Mac Basics and Help' started by mr.macbookpro, Jan 13, 2009.

  1. mr.macbookpro macrumors newbie

    Joined:
    Jan 13, 2009
    #1
    hi just got a used macbook pro 15 inch
    and did fresh install of mac os x
    and the following things dont work if u could help that would be great

    sound
    youtube vids(loads vids but cuts out after 2 secs)
    top shortcuts on f keys
    im new to mac so dont kno if there is a right click if yes then that 2 plz hel me guys

    im using mac os x 10.5
     
  2. madog macrumors 65816

    madog

    Joined:
    Nov 25, 2004
    Location:
    Korova Milkbar
    #2
    Apple Menu (upper left corner), System Prefs, Keyboard/Mouse, Keyboard tab, uncheck the box at the bottom (use F1 ase standard function keys), to get them to work as shortcuts, i.e., volume up/down, screen brightness and all that.

    Since you did a fresh install, I would recommend hitting up the Apple Menu again and running the Software Update (like Windows Update) to update to the newest version available for your OS, java/security updates and all that. Depending on when the machine was released and the version of the OS that is on your system disks, you may have to run it at least 2-3 times.

    Also go and update all your flash/shockwave stuff via adobes site. These and the newest Java/Safari versions (these two will be installed via Software Update) should help out YouTube.

    The sound might be muted for some odd reason. Go to the Sys Prefs again and head into the Sound pane. Make sure the line-out is directed to your internal speakers (if nothing is listed there, then there may be a hardware issue with the sound board) and adjust the volume. You can then move to the Sound Effects tab and play/select your system dialog sound to check it out.
     
  3. mr.macbookpro thread starter macrumors newbie

    Joined:
    Jan 13, 2009
    #3
    thanks but with the sound ive b een to system prefs and sound but its grey nd wont let me change it is there a driver that needs to bee install

    also the keyboard is wat u said but stil not work is there driver that need to be installed
     
  4. TechAge macrumors newbie

    Joined:
    Jan 7, 2009
    #4
    I think what's wrong is that it's on lock mode. Some of the settings in System Preferences has a lock in it so no one will be able to mess up your configuration unless they know your password.

    Go to the Sound in System Preferences and look at the lower-left of the window. There should be a lock symbol there. Click on that and it will prompt your password. After that, you can change the settings of your sound.

    Let me know if it works!

    EDIT*
    As for the keyboard, I don't think it needs a driver.
    Could you try holding the fn button located at the lower-left of the keyboard and press the function buttons?
     
  5. mr.macbookpro thread starter macrumors newbie

    Joined:
    Jan 13, 2009
    #5
    ok ill try for sound but ive tryed fn button still not work

    thanks for idea but thers no lock in corner of sound its on mute and i cant change it its gone grey pls help if u can
     
  6. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #6
    TechAge is referring to the padlock icon in the lower left corner of the Sounds preference pane in System Preferences. If the icon is locked, you will have to enter your password in order to change settings. This is a security feature.
     
  7. TechAge macrumors newbie

    Joined:
    Jan 7, 2009
    #7
    Hmmm very strange for both. Could you do this for sound?
    Look for a type of file on your libraries: (library/preferences)

    com.apple.audio.DeviceSettings.plist

    If you see these files, drag them to your desktop, then do a restart.
    --------------------------------------

    As for the right-click, just do a Ctrl+Mouse Click.
     
  8. mr.macbookpro thread starter macrumors newbie

    Joined:
    Jan 13, 2009
    #8
    sound stiil wont work and itunes wont play for that reason i think at about youtube does any1 kno how to fix it youtube loads but 2 secs plays then cuts its not flash i have flash 10 plz help

    cant some 1 help
     
  9. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #9
    Could you upload a screenshot of your Sounds preference pane? (To take a screenshot, press command+shift+4 and drag a box around the area you want to capture. A file called Picture 1.png will appear on your desktop, which you can attach to your post.)
     
  10. mr.macbookpro thread starter macrumors newbie

    Joined:
    Jan 13, 2009
    #10
    i took it have a look if u need anything esle BlueRevolution like other shots just say
     

    Attached Files:

  11. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
  12. mr.macbookpro thread starter macrumors newbie

    Joined:
    Jan 13, 2009
    #12
    have a look
     

    Attached Files:

  13. TechAge macrumors newbie

    Joined:
    Jan 7, 2009
    #13
    Is Sound the only preference you can't modify?
    Look at the others like go to mouse/keyboard preferences or to Display preferences.
     
  14. mr.macbookpro thread starter macrumors newbie

    Joined:
    Jan 13, 2009
    #14
    yes and youtube wont work pls help techage
     
  15. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #15
    Try creating a new user profile (under the Accounts preference pane). Does the sound work there?

    We'll deal with the YouTube issue once the sound thing is resolved.
     
  16. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #16
    How exactly did you install the OS? What color is the disk?

    Did you buy Leopard?

    Since your keyboard did not default to laptop settings, I suspect you might have cloned a desktop Mac HD or have a non-legit install disk.
     
  17. mr.macbookpro thread starter macrumors newbie

    Joined:
    Jan 13, 2009
    #17
    i bought leopard
     
  18. mr.macbookpro thread starter macrumors newbie

    Joined:
    Jan 13, 2009
    #18
    but it was copied dosen that matter?
     

    Attached Files:

Share This Page