Help!! Problems with new Aperture & iPhoto library

Discussion in 'Mac Apps and Mac App Store' started by nealeholl, Jun 12, 2012.

  1. nealeholl macrumors member

    Joined:
    Oct 5, 2009
    #1
    I just updated Aperture (3.3) and iPhoto. When I launched Aperture, it told me to quit, and open my Aperture library in iPhoto. I did this, and it went through 9 stages of updating the Library. All looked ok, so i quit iPhoto and opened Aperture. However Aperture wouldn't let me open the Aperture library - it told me to go to iPhoto and update the Library there (like I just did!).
    I went back to iPhoto, only to find that "the iPhoto library is locked, on a locked disk etc...".

    Any ideas?

    I have rebuilt disk permissions. I have tried Alt-Option when opening iPhoto to rebuild the library (same message appears). Now I'm stumped :confused:
     
  2. macspacey macrumors newbie

    macspacey

    Joined:
    Jun 30, 2012
    Location:
    Brisbane, Australia
    #2
    Restart

    This happened to me the other day. Did exactly what you did with no luck. Restarted the computer and all was good - just had to specify which library to use.
     
  3. stoneage macrumors regular

    stoneage

    Joined:
    Sep 21, 2002
    Location:
    Directly above the center of the Earth.
    #3
    Me too. I can't open iPhoto. It tries to upgrade the library, gets to step 3 0f 9 and doesn't proceed, and ends up quitting after a while. Aperture has a similar problem after I updated to 3.3.1. It just won't open. Using Lightroom until this mess is figured out. I checked with Disk Utility and everything seems fine. Maybe the OS (10.7.4) is corrupted. Tried reinstalling Aperture and iPhoto with no luck.
     

    Attached Files:

  4. TonyK macrumors 6502a

    TonyK

    Joined:
    May 24, 2009
    #4
    After pulling down the updates I opened Aperture and it converted just fine. Told me I could open iPhone libraries now and proceeded to open and operate as usual.

    Sorry, wish I could provide some useful information.
     

Share This Page