Help removing a program

Discussion in 'macOS' started by Bill&Rose, Sep 9, 2008.

  1. Bill&Rose macrumors member

    Joined:
    Aug 23, 2008
    #1
    I tried to do a search for this problem but only got one item returned that did not apply.

    Here is the problem, I bought a Seagate Free Agent Pro external hard drive 500 gig for my iMac 24 inch system, the Seagate drive installed a program call Free Agent that does back ups, I did not want to use their program and dragged the folder into the trash to delete the program.

    Now I have an icon on the menu bar on the top right that I can not get rid of and Apples time machine does not seem to back up properly. I think this is because of the free agent program and icon.

    The icon belongs to the Sea Gate free agent program that was installed. I have tried to drag this icon off the menu bar but it will not allow me to do anything with it. It just stays in place.

    If I click on the icon it brings up the program selections i.e. the Sea Gate program running in the back ground. I turn that off but still can't drag the icon from the menu bar.

    From what I have read about OSX this means that something in the program the icon belongs to is still running and will not let me delete the icon until that program is shut down.

    I do not know what is running as I have deleted all the files I could find for the Sea Gate Free Agent back up program.

    Does anyone have any advice? :(
     
  2. Tallest Skil macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #2
    Hold the Apple key. Click the icon. Drag it off.
     
  3. Bill&Rose thread starter macrumors member

    Joined:
    Aug 23, 2008
    #3
    I have tried that and it does not work with this icon.

    I can move any of the other icons, i.e. the time machine icon will drag off the menu bar as will the blue tooth and the airport and sound icons, but this free agent icon that the Sea Gate software installed when I formatted the drive to the Mac format will not move.

    I am stumped.
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    First, check Activity Monitor to make sure the application isn't still running. If it is, stop it. Then remove the app by dragging it to the trash. While it's most likely in your Applications folder, you may want to search for it, in case it installs to a different location. Then you should be able to hold the Command key and drag the icon off the Menu Bar.
     
  5. Bill&Rose thread starter macrumors member

    Joined:
    Aug 23, 2008
    #5
    I can turn off the program Memeo Life Agent with the Activity Monitor, but when I do the icon disappears from the menu bar, I can't seem to figure out what the name of the file is for this program, i have tried searching Memeo Life Agent but search says nothing found, also other combinations.

    The icon will remain gone until the next time you start the computer then it is auto starting and back on the menu bar again.

    Any one know what this program is and how to get rid of it.

    I think it is from the Sea Gate Free Agent Pro software.

    My time machine does not back up correctly saying the back up failed. I can do a manual back up with no problem. I am thinking this program has something to do with this problem.
     
  6. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
  7. bobr1952 macrumors 68020

    bobr1952

    Joined:
    Jan 21, 2008
    Location:
    Melbourne, FL
    #7
    In the Activity Monitor did you try to highlight the process and "inspect" it--maybe there is another Seagate process associated with it--and you will also get additional information on the process this way.
     
  8. Bill&Rose thread starter macrumors member

    Joined:
    Aug 23, 2008
    #8
    I went to the memeo site, I did not know they were another company, I was thinking this was a seagate issue or program, but any way I found enough information on that site to locate the files and delete them and the icon is now gone.

    Now I just have to see if time machine will back up without the failed to complete back up showing up. That will have to wait until tomorrow. :eek:
     
  9. rvphog44 macrumors newbie

    Joined:
    Apr 28, 2009
    #9
    Yep Yep

    .


    I/m having the exact same problem. Kinda feels like I'm on windows or something............
     

Share This Page