Resolved Help, repeated corruption of Photos library on MicroSD

Discussion in 'Mac Basics and Help' started by RedTomato, Dec 30, 2016.

  1. RedTomato, Dec 30, 2016
    Last edited: Dec 30, 2016

    RedTomato macrumors 68040

    RedTomato

    Joined:
    Mar 4, 2005
    Location:
    .. London ..
    #1
    Hi all,

    I was running out of space for photos on my MBA, so following suggestions on MacRumors, I bought a Nifty MiniDrive SD adaptor and a SanDisk 200GB MicroSD:

    https://www.amazon.co.uk/gp/product/B017HOBQ9U/
    https://www.amazon.co.uk/gp/product/B00V62XBQQ/

    It cost around £100 for the two items. Reformatted the SD to OSX Extended (Journaled), and transferred my 65GB Photos Library to it. Opened Photos, all worked well. Lovely. Closed and opened it a few time, rebooted, all working lovely.

    A few days later, opened Photos again. Corrupted. Rebuild the library. Photos working again now. A few days later, the Photos library is corrupted again. Rebuilt the library. Working now. But i suspect it will corrupt again in a few days.

    I don't know what to do here. I tried Disk Utility First Aid, and it says:

    "First Aid Process has failed. If possible, back up the data on this volume."

    Under 'More Details' it says

    "Updating boot support partitions for the volume as required.
    Unable to unmount boot volume for repair.
    Operation failed ..."

    I tested Disk Utility First Aid with another SD card, 128GB, and it ran perfectly fine and gave much the same feedback as running First Aid on a healthy SSD or HDD.

    Any ideas how to stop the repeat corruption?

    Computer is a 2013 MBA with 128GB SSD on OSX 10.11.6 El Capitan.
     
  2. vkd, Dec 30, 2016
    Last edited: Dec 30, 2016

    vkd macrumors 6502a

    vkd

    Joined:
    Sep 10, 2012
    #2
    Do a test run with a lower capacity microSD card and see if you encounter the same problems. It may be a fault in the memory chip itself.

    I noted that your 200GB microSD is Class 10, which has a rating of up to 80 Mbit/s, and as there are 8 bits in a byte, this means only 10 Megabytes per second (10 MB/s). Even though the item is rated (on the Amazon sales page) as "Class 10 for full HD video recording and playback" and it says above that, "Up to 90 MB/s transfer speeds", this second statement does not concur with the card rating. If it really can transfer data at up to 90MB/s, then why is it only rated as a Class 10 device? It would seem that, following the standard rating system, to attain classification as a qualified transfer medium for 90MB/s, this would translate to 720 Mbit/s and Class 90. Whether any of this is relevant is a good question.

    Take home:
    Perhaps the chip's transfer speed is causing a bottleneck. Perhaps it is OK for intermittent data transfer but perhaps it is manifesting incapability of acting as an always-on or always-connected item.
     
  3. RedTomato thread starter macrumors 68040

    RedTomato

    Joined:
    Mar 4, 2005
    Location:
    .. London ..
    #3
    I don't really see what testing with another card would achieve beyond what I outlined above. My feeling is there's an issue with the setup.

    You are correct, which I didn't fully realise till I tested the card with Black Magic. It does around 87MB/s read and about 7-9MB/s write which is quite annoying. However it's not too bad for the intended use which is just to look at lots of photos in Photos and not do much editing. Importing photos will be slow but won't happen en masse very often.
    Photostream means most of the importing (generally from my partner's iphone) should take place automatically in the background.

    I took a closer look at the info given by Disk Utility on the Samsung MicroSD 200GB and the PNY Storedge SD 128GB (which has worked perfectly). Turns out the PNY StorEdge is GUID while the Samsung is MBR. Ah. That might be causing corruption issues from failure to unmount cleanly on shutdown. I had already noticed the Samsung couldn't be unmounted.

    OK. Transferred all 65GB of my photos to a spinny (30 mins), erased the Samsung, reformatted it. Still MBR. No option to format in GUID. Ah: I have to format the Nifty adaptor (shows in Disk Utility as "Apple SD Card Reader Media", which is why I overlooked it before.)

    Success. Formatting the Nifty container gives a GUID option. Transferred all my photos back (took 3-4 hours). Seems to be working fine now, and unmounts cleanly too. Disk Utility First Aid is now happy with the Samsung 200GB.

    Provisionally I think this issue is now solved.
     

Share This Page