Help Required Fixing G4 Powerbook Please...

Discussion in 'PowerPC Macs' started by Stan, Feb 19, 2006.

  1. Stan macrumors member

    Sep 1, 2003
    When I boot up my G4 PB, it sticks on the grey screen, at the point before the spinning grey circle appears. I figure that I might be able to fix this with a software restore, but the PB drive is also not reading any disks - it whirrs loudly and spits them out. Anyone know if it is possible to boot the G4 from an external drive, or using an iMac G5? It's a bit of a 'catch 22' situation at present.

    What I need to find out is a) is it possible to boot from an external drive, b) if it is, do I need to input a set of key strokes to activate the boot up (bearing in mind I can't see the on-screen instructions, and c) is there a way I can control the PB from elsewhere so I can see what I am doing (eg another monitor, or my iMac G5). I have treid rigging my PB to an external monitor, via S-Video, but again only the grey screen appears, so this seems unlikely.

    Thanks for your feedback, any would be most welcome. Cheers.
  2. TLRedhawke macrumors 6502

    Sep 17, 2004
    You can boot up from any external device, provided that it's connected by FireWire. To do this, hold Option while the machine is booting, and it will present you with all the available boot disks.

    If you wish to boot from another machine's hard drive, you have to first put that machine into Target mode, by holding "T" when the machine boots.
  3. Stan thread starter macrumors member

    Sep 1, 2003
    I have tried zapping the PRAM, resetting the NVRAM, booting into single user mode and doing a safe boot - none of these worked, the grey screen on the PB remains.

    So, at present, have managed to log into firewire target disk mode and the PBook icon is on the G5 desktop. Opened disk utility to repair & verify the disk but when I attempt to do anything on the PB, an error appears: "Verify and Repair disk “ ”
    Repairing disk failed with error Could not unmount disk"

    An additional problem is that Filevault on the PB is turned on. At present, the only folders I can access are apps, library, system and users.

    1. Is there any way I can log into my account on the the PB?
    2. Is there any way I can view the PB desktop on my G5?
    3. How can i run a disk check with the above error?
    4. Is it possible for me to log into system preferences on the PB (NOT the G5) to turn off filevault on the PB. Apple's site seems to suggest this is possible but doesn't say how

    Many thanks for your help
  4. TLRedhawke macrumors 6502

    Sep 17, 2004
    If you put the PowerBook into Target Mode, and Option boot the G5, you may be able to boot from the PowerBook's hard drive. If the option to boot from that drive does not appear, then the System folder (not System Folder) is borked, at the very least.

    My suggestion would be to boot from an OS X disc, and run Disk Utility from that disc (It can be accessed from the Utilities pull down menu), to attempt to repair the disk. Failing all of this, you should be able to retrieve any crucial data via the FireWire link, and then blow away the PowerBook, and start over.

Share This Page