HELP Restore from Time Machine!!

Discussion in 'iMac' started by galaxy7, May 20, 2015.

  1. galaxy7 macrumors member

    Joined:
    Jan 18, 2014
    #1
    So just got my iMac back from the shop where I had to get a new drive installed. I have a time machine (a WD Passport for Mac). I turned it on and it look like a brand new computer. Plugged in my time machine, open settings and turned time machine on. Restart the computer while holding command and R and nothing happens; nothing. Does a normal start up and I do not get any pop up asking me to restore from time machine. When I start up holding the option button, I do get the option to select the drive or the time machine drive. I select the time machine drive, but it still does a normal start up from there and never gives me any option to restore. I know how to "enter time machine" but I don't know what I'm doing when I get in there.

    I need to restore the entire computer and would like to take it back to where it was the last time it was good. What am I missing or doing wrong?

    Thanks folks!!
     
  2. galaxy7 thread starter macrumors member

    Joined:
    Jan 18, 2014
    #2
    So some homework tells me I probably don't have a restore partition so the command/R thing doesn't work. Why is the 'option' button not working once I select it?

    Can I restore the entire thing by entering time machine?
     
  3. MandiMac macrumors 6502

    Joined:
    Feb 25, 2012
    #3
    Some more info, please

    Which device do you have? As far as I know, Cmd+R and its Internet Recovery not work with older models.

    Booting from the TM drive does not help you at all, you need to get into the Disk Utility on your Mac. It is available once you've booted up, or (you guessed it) on the Recovery Partition.

    Even Migration Assistant can help here - what exactly did you try so far?
     
  4. galaxy7, May 21, 2015
    Last edited: May 21, 2015

    galaxy7 thread starter macrumors member

    Joined:
    Jan 18, 2014
    #4
    Well, I can't get any kind of recovery partition. I read about the migration assistant but didn't try it yet because I don't know what I'm doing. I don't know how to get into disk utility nor what to do when I get there.

    Only thing I've tried so far is restoring a few individual files by entering time machine. That works, but it's still not restoring my computer the way it was. Cause I'm also missing a bunch of stuff like iPhoto, pages, keynote, etc.

    Guess my big question is...I can't figure out or find how to get to any kind of screen or pop-up where it offers me the option to "restore from time machine". That's what I want to do...completely reimage it back to where it was the day before it broke.
     
  5. MandiMac macrumors 6502

    Joined:
    Feb 25, 2012
    #5
    Okay

    You said you're able to boot up the machine normally and it presents itself to you as brand new, meaning there are no users or programs on it that you installed earlier. Good.

    Click on your Applications or Programs Folder (I'm German, so I don't know how it is called in English specifically), and there should be a sub-folder called Utilities or something.

    In there, you should find the Migration Assistant you can follow step by step, where you can revive your Time Machine backup :) Users, apps and more. Good luck!
     
  6. galaxy7 thread starter macrumors member

    Joined:
    Jan 18, 2014
    #6
    Wow...migration assistant didn't work either. It opens, but my time machine never shows up as an option to restore from.

    Here's something I learned....my last backup that I want to restore from is Maverick. The computer now has Yosemite. Is this a problem.
     
  7. MandiMac, May 21, 2015
    Last edited: May 21, 2015

    MandiMac macrumors 6502

    Joined:
    Feb 25, 2012
    #7
    This is odd. You are sure that there is a backup on your Time Machine and it is in reach? I'm asking because I tried it now on my machine and it would work just as expected. How is the Time Capsule/HDD connected to your Mac?

    As for your question, yes, Time Machine works between iterations of OS X. See here for details.

    EDIT: I just googled the Apple Forums and found this little gem here. What struck me was this: "c. If the machine shipped with OS X 10.7 or later, you don't need media. It should start up in Internet Recovery mode when you hold down the key combination option-command-R at the startup chime. Release the keys when you see a spinning globe."

    Try that one again, this time with Option+Command+R. Internet Recovery should kick in. Again: Which Mac do you have?
     
  8. MandiMac macrumors 6502

    Joined:
    Feb 25, 2012

Share This Page