Help Restoring ibook g4

Discussion in 'PowerPC Macs' started by OUTofDMC, Feb 25, 2010.

  1. OUTofDMC macrumors newbie

    Feb 25, 2010
    I am trying to restore a ibook G4. I have the install discs. When I put the install discs in and turn off the computer a grey screen comes on telling me that I must turn off computer. I have tried turning on the computer while pressing the "c" button but nothing seems to help. The disc is clean and has no scratches.

    I also tried restring using restore utilities. I get the error "lost connection with help tools". I am trying to restore the computer to factory conditions. Any help would be great. Margaret
  2. smithmax13 macrumors member

    Jan 27, 2010
    I went through the same thing last month, but the "c" worked for me. Are you just restarting, or completely shutting down, then holding C when you start it back up?
  3. OUTofDMC thread starter macrumors newbie

    Feb 25, 2010
    I am completely shutting down because that what the instructions are telling me to do
  4. QEII Student IT macrumors regular

    QEII Student IT

    Nov 25, 2009
    Peel, Isle of Man
    Due to uselessness, I never use restore discs, I always Firewire Target Mode
  5. smithmax13 macrumors member

    Jan 27, 2010
    I had to use the restore disc because none of the ports were recognized. I have updated my OS by using an old firewire iPod and holding down C.
  6. OrangeSVTguy macrumors 601


    Sep 16, 2007
    Northeastern Ohio
    Are you using the discs that came with the iBook or discs that came with another computer?

    Try holding down the option key during bootup. This way you can see if your disc is showing up as a bootable disc.

    Do you have another Mac with Firewire? You can connect the two with a Firewire cable and use the other Macs optical drive and hold "t" during startup to boot into target disc mode.

    Also an external USB optical drive will work too if you have one of those laying around.
  7. OUTofDMC thread starter macrumors newbie

    Feb 25, 2010
    Router question also

    I tried the options button already. When I try to log on to the install disc all I get is a white line across the screen and it locks.

    On another note. I can't get into my wireless, short of using neighbors. Computer won't recognize WPA password. The name of the internet changed somehow. I want to delete it and add a new one but don't know how. Went to system preferences and in the network but couldn't find it. Do I have to reset my router? I work on my computer at home. I am not very computer savy and if I lost my internet. Well let's say it wouldn't be good.

    Thanks for all your help

Share This Page