Help - Safari error when sending videos by email

Discussion in 'macOS' started by pjmaudsley, May 16, 2007.

  1. pjmaudsley macrumors newbie

    Joined:
    May 16, 2007
    #1
    Hi - I have 3 accounts on my Mac. I'm the administrator. I hope this is right thread. I've started to have problems sending videos by email even though I've had no problem before. The funny thing is I have no problem with the sending videos on the other two accounts. I get Safari can't open the page; and this error: POSIX error: Invalid argument (NSPOSIXErrorDomain:22) Every time I click OK to attach I get this message. It's so frustrating because I send many videos and I have to use my son's account to send them. I'll be grateful if anyone can help:)
     
  2. orangemacapple macrumors 6502

    Joined:
    Sep 1, 2006
    Location:
    Raleigh
    #2
    i can't give you much help with safari -- i use firefox.

    but i find it very helpful and easy to use an ftp like xdrive.com. just upload your videos to there and send everyone the link to it. it IS much quicker and easier than trying to send them in an email. they can see or download it from the site. it doesn't take up your bandwidth and slow things down -- just like clicking on a link on a webpage. they don't have to wait while the email loads. if it's a large file, some people's email account won't let the large file through.


    the account is FREE and you get 5 Gigs storage for free.

    xdrive.com

    there are others out there too, like box.net (1Gb)

    i think you'll be very happy with the results.
     
  3. pjmaudsley thread starter macrumors newbie

    Joined:
    May 16, 2007
    #3
    Error POSIX Invalid argument NSPOSIX Domain:22 FIXED

    Thanks for the info.

    I found this worked on another forum I found through Google. Hope this will help anybody else with this problem.

    I tried removing various folders from my home library including Preferences, Internet Plug-Ins, Safari and Caches. The only one of those which had an effect was the Caches folder - when I removed that the uploading worked fine once again!

    So as a test I put the Caches folder back into the Library but left the Safari Cache folder out of it ... and that worked too! So presumably there's something up with that Safari Cache folder ... rather odd considering that Get Info says it takes up zero k, and it appears to be full of empty folders within folders ....

    Ahh well, at least things are working now!

    DON'T FORGET TO LOG OUT/IN after removing/replacing folders
    Peter
     

Share This Page