Help~Save my Ti please...

Discussion in 'Mac Pro' started by Looming, Jul 18, 2006.

  1. Looming macrumors newbie

    Jul 18, 2006
    I've bought the Powerbook G4 Merury in 2001 when I was in college, although I have a brand new mac now, but it is still my favorite one to have chats on bed before sleep.
    It worked well untill one day 2 months ago, it has now became easily to hang up. When ever i try to move the body of it, it hangs...and now, it became even worse, it sometimes doens't display after reboot. I can hear the hard drive is running but no display. I think it's a hardware problem cuz I have had the hardisk formated and reinstalled, nothing changed. Does anybody have the same problem ever?
    P.S, I have tryed my Apple Hardware Test Disk which comes along with the computer, it hangs after all test done successfully, and i think the last one was video test.
  2. disconap macrumors 68000


    Oct 29, 2005
    Portland, OR
    About two months ago? I suggest doing a complete reinstall of the OS if you can, it sounds like the problems a lot of PPC owners were having after the last OS update (the combined updates seem to be fine, however). Archive/install might fix the problem as well, it did on one of mine and didn't on the other...
  3. Looming thread starter macrumors newbie

    Jul 18, 2006

    I think it could be more complicated than a simple software bug. I'll repartition the disk and do a full reinstall tommorow.
  4. livingfortoday macrumors 68030

    Nov 17, 2004
    The Msp
    I'm kinda confused. When you say you move the "body" of it, do you mean the computer itself? Are you saying that moving it will make the computer crash? If that's the case, there's probably something loose inside of it. Did you recently drop it, or smack it hard or something? You may want to open it up ( has good guides for that) and check all the connections.
  5. Looming thread starter macrumors newbie

    Jul 18, 2006
    Yeah, the body means the computer. The last time i droped it was in September last year, it worked fine untill 2 weeks ago... yeah, I'm gonna open it, I knew that website, it used to be i think...
  6. JBot macrumors 6502

    Jan 9, 2006
    it could be the harddrive is just shutting down, because does macintosh have that whole, harddrive protection, when it notices movement it protects the disk and the laser? Thus sending the machine to sleep mode.
    But if it also occurs when its sitting still, like ona table or something, than that cant be the reason.
  7. Looming thread starter macrumors newbie

    Jul 18, 2006
    It Hangs... Again...

    I have put the harddrive on a pc and formated it, then put it back and repartitioned it with DU, installed a brand new OSX tiger, and this morning, i woke up, seeing the powerbook in sleep mode, i pressed enter to wake it up, it did woke up, after that, hangs... I restarted, when it comes to the blue screen, it hangs... i pulled the power cable out, and put it back, reboot, no display, pulled out again, wait for 10 seconds, yeah it comes out the boot screen, but still hanged at the blue screen.

    Now I have just used the Apple hardware test powerbook version 1.0 to test it... no problem...
  8. SC68Cal macrumors 68000

    Feb 23, 2006
    I'm having similar issues with my Ti Book. First I had kernel panics because of a bad memory module that I purchased, then last night I opened my powerbook, to only have a kernel panic happen as soon as I ran software update (Last few kernel panics caused by ram corrupted files, so I had to reformat) and then the computer refused to start up. It would sit at the apple logo, hard disk would park the head and the computer would shut off.

    Popped in cd, booted up, verified and repaired the disk, with no luck. Errors would still show up. Decided to go for broke, formatted the hard drive and reinstalled, software update still does not work correctly.

    I'm worried my hard disk is at fault.
  9. generik macrumors 601


    Aug 5, 2005
    It's a Ti powerbook, the motion sensor was only very recently added to the PBG4 (very recently relatively speaking!)

    I suspect a loose connector myself.

Share This Page