OS X HELP: Screen Saver starts while I'm playing

Discussion in 'Mac and PC Games' started by minifridge1138, May 16, 2019.

  1. minifridge1138 macrumors 65816

    Joined:
    Jun 26, 2010
    #1
    Hello everyone,

    TLDR - Does anyone know how to give my game permission to auto-disable my screensaver?

    The long version:
    After a recent MacOS update (10.14.X I think, but I don't remember exactly) I launched one of my Mac Games. I wasn't paying much attention and clicked through a dialog box saying something like "This game would like to access your system's accessibility settings." I wasn't really paying much attention and did not grant the request.

    Now whenever I start playing the game, my screensaver starts and blocks the screen. This didn't used to be a problem but I can't figure out how to fix it. The only thing I can do is go to System Settings and disable my screensaver before I start playing.

    Does anyone know what I can do to fix this or am I cursed to a lifetime of manually disabling settings?

    Thanks!
     
  2. Ritsuka macrumors 6502a

    Joined:
    Sep 3, 2006
    #2
    A game doesn't need to request the accessibility permission to disable the screensaver…
     

Share This Page

1 May 16, 2019