Help sending e-mail thru comcast????

permie

macrumors newbie
Original poster
Jul 8, 2007
2
0
Been having problems the last few days sending/forwarding e-mails. Keep getting "connection to the outgoing server smtp.comcast.net failed".

Have reset the phone and tried everything else I can think of and still no success. Anyone have a solution???
 

Macxor

macrumors newbie
Jul 26, 2007
17
0
If you go into your mail settings and change the outgoing SMTP mail server to cwmx.com your comcast mail will send. Once you attach to your home WIFI you will need to change it back to smtp.comcast.net.

This seems to be the common workaround used by other Comcast subscribers.
 

richsim

macrumors newbie
Jun 25, 2007
7
0
The problem with cwmx.com is that it doesn't work when you're using WiFi.

A better solution is to use a different mail port, one that Comcast will accept. Comcast blocks the standard port 25 when you're sending mail from outside their system. I found that port 465 works for my Comcast account. (Don't know if it matters, but I'm located in Massachusetts. Port 587 is one that people use with other providers, but it didn't work for me.)

To set it up, go to Settings/Mail on your iPhone, select your account, and scroll down to "Outgoing Mail Server (SMTP)". Then enter these settings:

Host Name:
smtp.comcast.net:465

User Name:
Your Comcast mail user name (without the @comcast.net)

Password:
Your Comcast mail password

Under the advanced tab:
Outgoing Uses SSL is ON
Authentication is set to Password
 

docpjk

macrumors newbie
Jun 15, 2007
2
0
The problem with cwmx.com is that it doesn't work when you're using WiFi.

A better solution is to use a different mail port, one that Comcast will accept. Comcast blocks the standard port 25 when you're sending mail from outside their system. I found that port 465 works for my Comcast account. (Don't know if it matters, but I'm located in Massachusetts. Port 587 is one that people use with other providers, but it didn't work for me.)

To set it up, go to Settings/Mail on your iPhone, select your account, and scroll down to "Outgoing Mail Server (SMTP)". Then enter these settings:

Host Name:
smtp.comcast.net:465

User Name:
Your Comcast mail user name (without the @comcast.net)

Password:
Your Comcast mail password

Under the advanced tab:
Outgoing Uses SSL is ON
Authentication is set to Password

Wow! thanks for solving a big problem for me!!!!!!!!!!!!!!!!!!!!!
 

JamieK

macrumors newbie
Feb 26, 2011
1
0
Oh thank God you guys are brill

I have spent the past two hours trying to fix my parents email ... they use Comcast. After desperation set in, I checked this site and found your collective advice and it worked. I feel like the weight of the world has been lifted off of my shoulders. And I will look like a genius to my 70-year-old parents! Bless you all!
 

pradcliffe

macrumors newbie
Oct 28, 2013
1
0
Thank You!!

The problem with cwmx.com is that it doesn't work when you're using WiFi.

A better solution is to use a different mail port, one that Comcast will accept. Comcast blocks the standard port 25 when you're sending mail from outside their system. I found that port 465 works for my Comcast account. (Don't know if it matters, but I'm located in Massachusetts. Port 587 is one that people use with other providers, but it didn't work for me.)

To set it up, go to Settings/Mail on your iPhone, select your account, and scroll down to "Outgoing Mail Server (SMTP)". Then enter these settings:

Host Name:
smtp.comcast.net:465

User Name:
Your Comcast mail user name (without the @comcast.net)

Password:
Your Comcast mail password

Under the advanced tab:
Outgoing Uses SSL is ON
Authentication is set to Password
OMG. I was afraid to do this as I'm very technically challenged but I bit the bullet and made the changes you suggested:D. Worked like a charm. Thank you!