Help Sony Handycam transfer from PC to Mac

Discussion in 'Mac Basics and Help' started by azosel, Nov 18, 2009.

  1. azosel macrumors newbie

    Joined:
    Nov 18, 2009
    #1
    So my problem is I just got a macbook and I am transferring my files from my pc to my mac. My old sony handycam videos on my mac will not transfer. It says on my mac that "this is not a movie" and cannot be played. I have tried saving a video to a flash drive and doing it that way but no luck. I have figured out how to download videos from my handycam to my mac. I just need help getting my videos from my pc to my mac. Do I need to convert them to a different format?

    I am getting rid of my pc and am desperate to get these video's off. Please help!!!

    Also my burner is busted on my pc so I cannot just burn them either:(
     
  2. patrick0brien macrumors 68040

    patrick0brien

    Joined:
    Oct 24, 2002
    Location:
    The West Loop
    #2
    Sounds like you have several challenges here, but I'll try with the base one: the movies.

    What is the extension of the movie files on the PC? .avi, .wmv, etc...
     
  3. azosel thread starter macrumors newbie

    Joined:
    Nov 18, 2009
    #3
    The movies are all MPG files but in the folder when you look they have a file that goes with them and it is a MODD file. So in the folder they have a MPG file #12345 then beside that a file #12345.modd, and the next video is the same, etc..
     
  4. patrick0brien macrumors 68040

    patrick0brien

    Joined:
    Oct 24, 2002
    Location:
    The West Loop
    #4
    Well, MODD is something quasi-proprietary to Sony, an it disturbs me a bit.

    It sounds like you should be able to transfer them to your Mac, but getting the Mac to read the MPG file if that file depends on the MODD, I just don't know. This is a new one on me. Do you still have the videos on the camera?

    We could circumvent this whole mess if you just imported them onto the Mac from the Camera. IT's a PITA, but at least you know it'll work.
     
  5. azosel thread starter macrumors newbie

    Joined:
    Nov 18, 2009
    #5
    They are not on the camera that is the problem. If anyone has any ideas please let me know.
     

Share This Page