(Help) Stuck at grey screen

Discussion in 'MacBook Pro' started by Namtaro, Aug 23, 2012.

  1. Namtaro macrumors regular

    Joined:
    Dec 4, 2011
    #1
    I have my Macbook shared so I can access files on his Mac on my computer... but I didn't want anyone else in the house to access my core drive so I set the permissions on 'everything' to nobody. Well now when I tried to turn on my Macbook I get the Apple Logo with a loading spinning circle infinitly. Set it aside for an hour and it didn't go further.

    I tried safe booting (held shift after start up tone and let go when apple logo started) and now I have a blank grey screen with the mouse working.

    Any help?

    I'm fine with reformatting the machine if I have to, but I can't access anything...
     
  2. Namtaro thread starter macrumors regular

    Joined:
    Dec 4, 2011
    #3
    I didn't have timemachine setup with this machine since I don't have any extra external harddrives laying around so I kept it free of important data. I went ahead with the reformat... mid way through I see your thread. :p

    Booted into my recovery partition and clicked install mountain lion... it asked for my Apple ID and started downloading Mountain Lion. While I was getting all my apps ready for installation, a few hours later it finished. Restarted the Macbook and it went to the login screen asking for a password. Odd I thought as I never gave anything for a password while it was installing so I just try my old password. What do you know, it boots up to my machine before it all happened.

    I have no idea what happened but that just really surprised me. Guess I'm lucky I didn't format the drive before reinstalling...
     

Share This Page