Help! System Upgrade?

Discussion in 'macOS' started by donnetrav, Nov 25, 2012.

  1. donnetrav macrumors newbie

    Joined:
    May 28, 2011
    #1
    Hello. I currently own an iMac G5 — purchased on eBay 2 1/2 to 3 yrs ago.
    It did not come with any CD's. However, it was loaded with the usual apps.
    I am currently running OS 10.5.8. I believe it is the first of the Lion apps. I am experiencing multiple download problems. I'm thinking that I need to upgrade to a later system. Can I upgrade to "Mountain Lion" or "Snow Leopard"? Would
    this possibly solve my problem? I am looking for any in-put on this matter. This is my first machine with all the new apps & gadgets. I previously and still own a G4 "Mirrored Door" Power Mac. Please help. Thanks ever so much.
     
  2. SuperJudge macrumors 6502

    SuperJudge

    Joined:
    Apr 2, 2008
    Location:
    The Triangle, NC
    #2
    10.5.8 is Leopard, and is, unfortunately, the newest version of OS X that you can run on an iMac G5. I would recommend tracking down a Leopard disk, but they can be prohibitively expensive.

    Are you absolutely sure that you have an iMac G5?
     
  3. donnetrav thread starter macrumors newbie

    Joined:
    May 28, 2011
    #3

    Yes. Below is info from "About This Mac":

    Model Name: iMac G5
    Model Identifier: PowerMac8,1
    Processor Name: PowerPC G5 (3.0)
    Processor Speed: 1.8 GHz
    Number Of CPUs: 1
    L2 Cache (per CPU): 512 KB
    Memory: 2 GB
    Bus Speed: 600 MHz
    Boot ROM Version: 5.2.2f4
    Serial Number (system): W85050WEPP8
    Hardware UUID: 00000000-0000-1000-8000-000D935CE070

    I am experiencing "FLASH PLAYER" download problems.
    Message keeps saying something like: "download not accepted by this
    architecture" — whatever does this mean. Thanks:confused:
     
  4. SuperJudge macrumors 6502

    SuperJudge

    Joined:
    Apr 2, 2008
    Location:
    The Triangle, NC
    #4
    You need to download Flash 10.1 since that was the last version compatible with PowerPC Macs. You can get it here. I'm willing to bet that the errors you're seeing are because you're downloading and trying to install version of software that are too new.

    You might find this thread helpful.
     

Share This Page