HELP! The disk you inserted was not readable by this computer

Discussion in 'Mac Basics and Help' started by milner007, Jul 14, 2006.

  1. milner007 macrumors newbie


    Mar 12, 2006
    I have a MBP and i have a 300gb ext harddrive that was perfect till yesturday
    when i went in to windows and somehow changed the harddrive to ms-dos format without formating the harddive. Now both OS want to format the hard drive beacause they cant read it and i was wondering is there a way to change the format back to OS-x format withour formating because the information is still on the hardrive just not in the right format. If windows can do change it that easy Mac should be able to turn it back easy to. Theres hours of work on the harddrive and if anyone can help me not have to format the hardrive i will be forever greatful.I also run initialize then run disk repair and a error comes up and the fast aid fails.

    Can any help me :confused:
  2. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    Are you sure the formatting changed? You can't change the format of a drive without erasing everything on it too, unfortunately. How does Windows react when you plug it in? Could you try it on a different machine? :)
  3. milner007 thread starter macrumors newbie


    Mar 12, 2006

    Windows wants to format the harddrive and i have tried on my home PC
    and it still says the same thing
  4. alexstein macrumors 6502a


    Aug 23, 2004
    Something must have gone wrong along the way. I hate to say it but I think your data of that drive is gone.

    Just choose a platform you want to format your Drive in and stick with it. If you need a EHDD that you can use with both platforms (pc, mac) format it in FAT32. However if you go that route keep in mind that there is a GB limit on FAT32 formatting. (I think it's like 137GB or some weird number like, do a search)
  5. CRHersh23 macrumors newbie

    Aug 19, 2009
    I am having the EXACT same problem. Were you able to resolve this??
    I used Data Rescue II to get most of the files off my drive, but some didn't make it, nor did the file names or the folders in which the files were organized...
  6. Tumbleweed666 macrumors 68000


    Mar 20, 2009
    Near London, UK.
    Google for data recovery programs.
  7. cirtap macrumors newbie

    Dec 14, 2009

    Same problems stated above.

    Dealing with a MBP

    My External 500g Barracuda stopped showing up on the desktop.
    Not knowing a lot about computers, I was like "okay, haven't used it anywhere else than my own, must be the case.
    Bought a Raid Dual case and then started getting "The disk you inserted was not readable by this computer". :eek:
    So I bought a new 1TB WD HDD. Brand new, right out of the package. I plug into my new case, same message: "The disk you inserted was not readable by this computer"
    This leaves me to believe my original HDD is fine and it must be my computer.
    I've now plugged both into my roommates computer. same error message.
    Do I need to reformat? I reset the PRAM and tried to Update the Firmware by making a ISO disk. it failed.
    It shows up in Disk utilites as "Config AL25744_12345678 Media"
    Cant repair, cant erase.

    please help! I have all my Pro tools sessions on here!
  8. Tumbleweed666 macrumors 68000


    Mar 20, 2009
    Near London, UK.
    Similar symptoms. Doesn't mean or even make it likely its the same problem.

    How about, its the drive, it failed ?

    It leads me to believe that the first disk failed and the new one needs a format before you can use it. Or possibly, there is something wrong with your new case, cable, or USB connection, or the new disk is DOA.

    OK now we are back to my first guess, original disk failed, second one needs formatting (or was DOA, I've had it happen). Or the case/cable connection is faulty. Or you are not supplying enough power to it. How are these disks powered? USB or separate power block? I have a USB disk case that needs two USB connections, one for power/data and the other just for power. Are you certain you connected it all up right. Did you RTFM for this case? Same on your room-mates computer, maybe thats the other common factor to all this, you, perhaps you are making the same mistake on both computers, maybe with power supplies or cables?

    Now you are panicking and trying black magic, it doesn't work on your roomates computer, so why would you mess with unrelated stuff on yours, thats clearly not the issue.

    Does it say "Cant repair, cant erase" on the screen or is that your diagnosis? The fact it can read the name (is this the new disk or the old one?) seems to indicate its working at some level.

    Backups ? Or did you think this was a special HD guaranteed never to fail?
    Did you try data recovery apps?
  9. Fishrrman macrumors G5


    Feb 20, 2009
    To the original poster:

    The 300gig drive that's giving you problems:
    Does it use an external power supply, or does it run off of "USB power"?
  10. pavarchive macrumors newbie

    Sep 13, 2010
    Here is how I cured my disk..

    I got the same problem today..had to reboot the system cause my snow leopard refused to respond and the "beach ball of fury" was going through some major uncontrollable over-time spin..

    Anyway when you see the message "The disk you inserted was not readable by this computer" you get 3 options; initialize, ignore and eject. GO TO initialize!

    In the new window Click on your external hard drive and choose "repair" in the bottom right corner of that very same window..

    I hope it helps.
  11. ElAvila macrumors newbie

    Nov 4, 2010
    I'm freakin out cause I don't have the option to REPAIR. It is faded out and I can't click on it. Before the name of my HD was Mahoney's Passport, but now on he Disk Utility program it doesn' show that name. It has like it's original name. Oh and when I have finder window open it doesn't show it's even plugged in. My external is a "My Passport" by WD. I'm pretty sure it's ****ed but it still "vibrates" after I plug it in and the light comes on and after a while I get the message that says "The disk you inserted was not readable by this computer."

    I just wanna know if all the files and things on the HD are gone forever or what I should do next??

    I should mention that last night it fell on the floor but it worked fine afterwards. However before it fell for weeks now I keep getting an error saying it disconnecting because the cable from USB into the HD was loose. Then tonight when I got the error again I got upset and I knuckle hit the external hard drive, since then it hasn't worked. Stupid reactionary me, couldn't control my temper. Now I just wonder if all my videos and photos from my African trip are gone forever and ever?!?!?

    If anyone has any ideas please contact me ASAP. Thanks alot.
  12. woowoodengy macrumors newbie

    Nov 22, 2009
    for those of you having this issue and need to get your files back there is a way to get the files.

    You will need to remove the drive from the enclosure and install it in a pc. (find a friends or something)

    Then boot off of a live linux cd, i recommend linux mint since its easy for the average user.

    you will be able to see all your files and copy them to another drive (just not formated to mac journaled since linux cant write to a mac journaled formated disk)

    hope this helps and never listen to someone online that says you cant get your files back and just format. thats just stupid.
  13. Innocey macrumors newbie

    Mar 11, 2012
    This might help

    Hi all,

    This might help others that were in my situation who found this thread! It did the trick for me and it was free too! It took under 5mins (going through the process with caution) to get my drive recognised again on my Mac.

    Just a word of warning for others in case they are thinking of using recovery software. I bought Disk Drill in a panic buy yesterday. It recovered the files, took 17 hours and they did not have ANY filenames and NO folder structure! What a useless piece of software! I had 300,000 files with no names!!! Utter rubbish!


  14. Clive Timmons macrumors newbie

    Apr 30, 2012
    Hi I have a 2TB external drive that I cannot access there are some important files that I need is it possible to get them recovered or could there be a chance that it is hopeless I'm desperate

Share This Page