Help: 'The "ipod" could not be restored. An unknown error occurred (1604)

Discussion in 'Jailbreaks and iOS Hacks' started by coreanomac, Jan 29, 2008.

  1. coreanomac macrumors member

    Joined:
    Jan 27, 2008
    Location:
    Connecticut
    #1
    Ok. Let me explain what I did (I think I mess up something) let me know If someone can help me out.


    I have a 1.1.2 Jailbreak iPod Touch until yesterday. I did the (Nate) 1.1.3 update everything was OK, but I miss my fav apps (Mail, Notes, Weather, Maps). I went to Installer I try to downloaded back but nothing happend.

    Then I read in some place that the Nate 1.1.3 was only for the iPhone. So, I try a few things (download "iPhone1,1_1.1.1_3A109a_Restore.ipsw" put the iPod Touch on restore + press Option Key and click on "restore" or "update" on iTunes + select "iPhone1,1_1.1.1_3A109a_Restore.ipsw", but NOTHING happend so, nevermind, so I end up updating to 1.1.3 from iTunes 7.6.

    Now... my touch is in recovery mode since yesterday. I can't even restore back using iTunes.. cause this message came up: "Help: 'The "ipod" could not be restored. An unknown error occurred (1604)"..


    Please any help I'll appreciate.

    Thanks.
     
  2. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #2
  3. TheDiggin macrumors newbie

    Joined:
    Mar 3, 2008
    #3
    The Same Happened To Me!!!!

    Hey coreanomac,


    The same error poped up for my iphone and im in the same **** as you.

    if u found the answer plz tell even if u didnt lets share the greef.

    TheDiggin.
     
  4. carfac macrumors 65816

    carfac

    Joined:
    Feb 18, 2006
    #4
    It is a communications problem. Unplug your USB cable and plug it intop another USB port. Try again.
     
  5. a7xscreamo macrumors newbie

    Joined:
    Mar 3, 2008
    #5
    Here's how you fix it: restore your iPod through the regular (not holding option/shift and clicking) process. Once it's all fixed and up to 1.1.4 put it into DFU mode, restore back to 1.1.1 and slowly make your way back up to 1.1.3 or 4 after jailbreaking. I did it last night so i know it'll work for you.
     
  6. swearbymac07 macrumors member

    Joined:
    Dec 13, 2007
    #6
    On a Mac

    Download iFuntastic, go to Setup and iTroubleshooting, click Exit Recovery Mode / Restart Device (its a Button). It will kick the iPod or iPhone out of this stage. Then reinstall iTunes. And sync.

    On a PC

    Download iPhuc, open up 'Command Prompt in Windows'. CD to the folder where you extracted iPhuc, then type 'cmd fsboot' then the iPhone/iPod will be back to normal. Then reinstall iTunes. Sync.

    Cheers

    This worked for me, if it is stuck in Recovery and will not Restore.
     
  7. jdevmiller macrumors newbie

    Joined:
    Jan 9, 2010
    #7
    Thanks so much

    Dude whoever you are you are awesome. I just got an iTouch this week and this very same thing happened to me when I tried to update the software. Thanks
     
  8. epb613 macrumors newbie

    Joined:
    Feb 11, 2010
    #8

    Thanks!! This worked for me too!
     

Share This Page