HELP: Time Machine, intermittent "NetAuthConnectToServerSync failed with error: 64"

Discussion in 'macOS' started by theosib, Jan 13, 2011.

  1. theosib macrumors member

    Joined:
    Aug 30, 2009
    #1
    Hi, everyone,

    Short version: Only one of three Macs has trouble backing up to my network drive, the authentication failure is intermittent, and only for automatically scheduled backups.

    Long version:
    I have three Macs backing up to a Linux box running netatalk. The latest version of netatalk is only missing two features MacOS X wants for TM support, and they have to do with unreliable network connections, so this should work great. In fact, it works perfectly for two of my Macs. Absolutely no problems at all. Rock solid.

    But for a third one, I'm having intermittent authentication failure. This is the error I get:

    1/12/11 6:50:56 PM com.apple.backupd[31596] Starting standard backup
    1/12/11 6:50:56 PM com.apple.backupd[31596] Attempting to mount network destination using URL: afp://millerti@compute0._afpovertcp._tcp.local/BackupDrive
    1/12/11 6:50:56 PM com.apple.backupd[31596] NetAuthConnectToServerSync failed with error: 64 for url: afp://millerti@compute0._afpovertcp._tcp.local/BackupDrive
    1/12/11 6:50:56 PM com.apple.backupd[31596] Attempting to mount network destination using URL: afp://millerti@compute0.local/BackupDrive
    1/12/11 6:50:59 PM com.apple.backupd[31596] NetAuthConnectToServerSync failed with error: 80 for url: afp://millerti@compute0.local/BackupDrive

    I've done a fair amount of investigation, and I've found a number of possible solutions that I've tried. For instance, since I used to use SMB, and now I'm using AFP, the way AppleDouble and other metadata is stored has changed, so I had to clear that all off. I also wiped all relevant entries from my keychain.

    What's odd is that it's intermittent. I NEVER have trouble manually mounting the network drive or the sparsebundle. In fact, if I go to the Time Machine menu and tell it to "Back Up Now", that never fails. Indeed, quite often, the automatically timed backups will work just fine. But every now and then, I'll get this authentication failure.

    Can anyone give me some insight into things I might try to resolve this problem?

    Thanks.
     
  2. theosib thread starter macrumors member

    Joined:
    Aug 30, 2009
    #2
    Further investigation

    Further investigation reveals that the authentication is stored in the System keychain. If I start TM manually from the menu, it must be using my personal keychain or something.

    I tried deleting the system keychain and creating a new one (rebooting, etc.), but that doesn't seem to have helped at all.

    The contents of the keychain entry are correct, so I think time machine must be having trouble accessing the keychain. Any ideas how to investigate this?
     

Share This Page