Help to identify loose "connector" in iMac, 1 memory slot not working

Discussion in 'iMac' started by Nick L., Dec 9, 2010.

  1. Nick L. macrumors newbie

    Joined:
    Dec 10, 2008
    #1
    I recently did an upgrade to add additional SSD to iMac 27' mid 2010, with all the official cables, bracket, etc.

    everthing worked great.
    but now 1 day later i discovered that my 16GB show up as 8GB!
    after testing every memory slot separately - turns out Upper right memory slot now cant read any RAM (Ram is fine in all other slots). When i start mac with any memory in this slot alone - the screen is black and its a beep with a long pause, then a beep again (having 2 RAM modules in upper row - same thing)..

    I know the slot was working before - since I tried 16GB before SSD upgrade.
    So with all 4 memories it shows up as 8GB. when i remove RAM from this upper right slot - 12GB get registered from the remaining 3 slots.

    After removal of logic board I think, i've heard a tiny loose part and found that loose "connector".
    I just kept it.
    Now I have all the reasons to believe that this connector caused this 1 memory slot to be not working.
    Anybody recognizes what could that be?

    if you could mark on these photos of logic board where to pay a very close attention (obviously somewhere in memory slots).
    http://guide-images.ifixit.net/igi/ktLKDUFPyGmyPPQJ
    http://guide-images.ifixit.net/igi/g1q3TMAZD1skKwhG


    Thank you.
     

    Attached Files:

  2. wingzero1285 macrumors member

    Joined:
    Aug 22, 2010
    #2
    That piece is on the "top" (where the cpu drops into its socket) of the logic board. It resets the SMC when pushed in. Its like a small switch. If memory serves me right, it was labeled SMC RESET in white, printed on logic board.
     
  3. Crwoo macrumors newbie

    Joined:
    Dec 7, 2010
    #3
    Warranty

    Were you able to get warranty since you did the upgrade?

     

Share This Page