Help! Top Keys on 13" MacBrook Not Working Properly!

Discussion in 'MacBook Pro' started by macgirl89, Sep 18, 2009.

  1. macgirl89 macrumors member

    Joined:
    Sep 4, 2009
    Location:
    New York, USA
    #1
    I just realized that the top row of keys on my MBP are not working right. All of the other keys are working fine (as you can see), but the top row isn't. For example, the brightness keys do absolutely nothing. When I press the key to increase the volume, it gives me Dashboard instead. When I press the key to lower the volume, it makes the window I have open go up (not sure what that's called, technically). When I press the play/pause key, I get Spaces. I don't know why the keys are all screwed up. I have not spilled any kind of liquid on the keyboard.

    It really bums me because I'm new to Mac and this MacBook Pro is not even two months old. Does anyone know what this problem may be and how to fix it?!
     
  2. Mew2468 macrumors regular

    Joined:
    Apr 11, 2009
    Location:
    Home of the 2010 Winter Games
    #2
    Try going to System Preferences -> Keyboard, and see if "Use all F1, F2, etc. keys as standard function keys" is enabled. If it is, try disabling it.
     
  3. macgirl89 thread starter macrumors member

    Joined:
    Sep 4, 2009
    Location:
    New York, USA
    #3
    Oh my God, thank you so much!!! That did the trick! You really made my night. I was going crazy thinking about how I'd have to bring this thing into the Apple Store. Thanks again!:D
     
  4. Mew2468 macrumors regular

    Joined:
    Apr 11, 2009
    Location:
    Home of the 2010 Winter Games
    #4
    No problem, glad it worked. :)
     
  5. mustangsally82 macrumors member

    Joined:
    Oct 19, 2006
    #5
    I had the same brief moment of panic when I got my MBP last October. I had upgraded from a five-year-old PowerBook and it seemed totally new. ;)

    If you want to access the other functions of the keys, just hold down the Function key (fn) and then press the F key. Then you don't have to go back into System Preferences.
     
  6. mrsir2009 macrumors 604

    mrsir2009

    Joined:
    Sep 17, 2009
    Location:
    Melbourne, Australia
    #6
    That happened to my friend on his MacBook. What was causing his was having voice over turned on. Try going into the system preferences and going into uni access and turing off voice over and all other uni access features.
     

Share This Page