Help! Tried to restore jailbroken iPod, now stuck

Discussion in 'iPod touch Hacks' started by catherine Babin, Jun 4, 2015.

  1. catherine Babin macrumors newbie

    Joined:
    Jun 4, 2015
    #1
    Hello,
    I wanted to restore my iPod touch 2nd gen. I think I did it the wrong way, or was not patient enough and now, my iPod is stuck on the jailbreak logo (with a stuck waiting wheel on front of it).

    Here's what happen :

    - I went to Settings/General and did a "erase all and restore ipod"
    - It took a very long time, and it was just going from the Apple logo to the Jailbreak logo, without end (for about 1 hour). So I thought it was stuck. I don't remember what I did exactly after that, if it was to hit the home or the power button, or whatever.
    - So I went online to find help to unstuck it. I saw many videos that explained how to restore in DFU mode and I tried everything to have that image that shows a usb cable, an arrow and a circle but I never get it. I can shut the iPod while pressing home+power button, but whatever I do to open it back, it will just show the Apple logo for a while, than it turns to the jailbreak logo and gets stuck there. I feel like I tried everything.


    Please, can someone give me a hand with this?

    - Just as I was finishing writing this message, the screen kinda flashed, and it went back to the Apple logo, and after the jailbreak logo, with the "waiting wheel" (how do you call this?) and now stuck again.
     

Share This Page