Help turning off DCHP on a D-Link router

Discussion in 'Mac Basics and Help' started by 7on, May 23, 2011.

  1. 7on macrumors 601

    7on

    Joined:
    Nov 9, 2003
    Location:
    Dress Rosa
    #1
    I'm having an issue (in a corporate environment) getting the Wireless router's DHCP turned off so everyone (LAN and WAN) can be on the same network.

    Currently internet works, but I can't print or access the network shares. I had to reset the router as we're getting a new employee today and the boss asked me to set her up.

    We had a guy who set this up once however he's no longer with the company. Attached is the router settings and I assumed all I had to do was uncheck the DHCP and change the IP to a 10.70.76.xxx address of the building. However the page complains that "LAN and WAN IP Address cann't be set to the same subnet." I have never needed to change subnets before and I surely don't want to screw the box up making me have to reset it again.

    Any help? Thanks!
     

    Attached Files:

  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #2
    Err... wait a minute. Why do you need to turn off DHCP in the first place? Why does the new user require a 10.x.x.x IP address? Is your internal network using the 10.x.x.x private address space, and when you defaulted the router it went back to 192.168.0.1?

    I can see why you would want to revert back to 10.x.x.x, but not why you'd need to turn off DHCP. A common gateway address for a router in that address space is 10.0.0.1 with a subnet mask of 255.0.0.0 . You'd want the DHCP address range to be 10.0.0.2 to 10.255.255.255 (or a smaller range if you want, depending on how many machines you have).

     
  3. 7on thread starter macrumors 601

    7on

    Joined:
    Nov 9, 2003
    Location:
    Dress Rosa
    #3
    Yes the internal network is 10.x.x.x.

    We want the computers on the wireless network (this dlink) to be on the same network as the printers plugged into the LAN on the building. I assumed the DHCP needs to be turned off as there is DHCP handling in the building.
     
  4. 7on thread starter macrumors 601

    7on

    Joined:
    Nov 9, 2003
    Location:
    Dress Rosa
    #4
    Found out the issue, I had to connect the WAN cable into the LAN slots. That seems to let me turn off the DHCP.
     

Share This Page