[HELP] Two-factor authentication (2FA) can ONLY be sent to device with iOS 10 but not iOS9?

Discussion in 'iPhone' started by striders, Sep 21, 2016.

  1. striders macrumors 6502

    Joined:
    Mar 11, 2009
    #1
    TLDR:
    - enabled 2FA from iPhone (9.3.5) - no 2FA pop-up
    - enabled 2FA from iPad Pro 9.7 (iOS 10) - 2FA pop-up shown

    I have 2 devices:
    • iPad Pro 9.7 with iOS 10 (upgraded from iOS 9.3.5)
    • iPhone 6S Plus with iOS 9.3.5.
    I decided to disable Two-Step Verification (2SV) and enable Two-Factor Authentication (2FA).

    At first, I enabled 2FA from my iPad --> Settings --> iCloud --> [My username] --> Password and Security. It worked just fine and when I login to icloud.com or appleid.apple.com from OTHER devices (MacBook, Windows machine, iPhone, etc.), I got the 2FA pop-up in my iPad, asking if I am allowing login from xxx place. If I click Allow, then the 2FA number will show up.

    However, this pop-up does NOT show up on my iPhone, only on my iPad. Thinking that maybe 2FA is specific to the device where I enabled 2FA, I did this:

    1. Go to appleid.apple.com and disabled 2FA
    2. Go to my iPhone 6S Plus (iOS 9.3.5) and enable 2FA from there: Settings --> iCloud --> [MyUsername] --> Password and Security
    Everything seems fine, but when I tried to login to iCloud.com or appleid.apple.com from OTHER devices (not the iPhone), I did NOT get the pop-up on my iPhone.

    I can generate the code by going to Settings --> iCloud --> [MyUsername] --> Password and Security --> Get Verification Code, but no pop-up.

    I rebooted the iPhone, disable 2FA and enable 2FA again from my iPhone but my iPhone NEVER received the 2FA pop-up. The iPad Pro 9.7 (iOS 10) also does NOT receive the 2FA pop-up. However, if I enable 2FA from my iPad, the pop-up ALWAYS show-up.

    Is this because iOS 9.x.x does NOT support 2FA? If not, can someone help me out? This is very troublesome since this is a security feature and I may ended up getting locked out from my Apple account.
     
  2. LGIR627 macrumors member

    Joined:
    Sep 9, 2016
    #3
    I think that link is outdated. I don't see the option to add trusted devices.
     
  3. striders thread starter macrumors 6502

    Joined:
    Mar 11, 2009
    #4
    Apple change it so if you use 2FA, "Trusted Device" is no longer an option in appleid.apple.com

    [​IMG]

    Yup.

    @All: it is now WORKING!! I don't know what caused the issue before, but prior to now, I did the following:

    1). Open Find iPhone app in my iPhone 6S Plus and let it find ALL of my devices
    2). Did the same for the iPad Pro 9.7
    3). After both app successful in finding all my devices, I got a alert box on my iPad Pro to enter my iCloud password.
    4). When I did, my iPhone show the Alert box to "allow/disallow" and when I click on "allow", I got the 2FA number.

    So far it has been working.
     

Share This Page