HELP! Unable to Install OS X on MacBook when trying to install Windows XP!

Discussion in 'Windows, Linux & Others on the Mac' started by sabor, Mar 17, 2006.

  1. sabor macrumors regular


    Mar 17, 2006
    I followed the instructions to install Windows XP on my MacBook. I had 3 partitions and Windows installer complained about not being able to install because of this. So I decided to follow the instructions and re-initialize my hard drive to 2 partitions.

    After doing so with Disk Utility, OS X will not install on any hard drive. When the disks to install show up, they all have an X on them and it warns that "You cannot install Mac OS X on this volume. Mac OS X cannot start from this volume". This happens on external firewire disks as well, it wont let me install on any of them (I have reformatted the drive to 1 partition and the problem persists).

    Any ideas on what I could do to get things back to normal? I am trying to think what could have happened when I reformatted the drive. Maybe the EFI partition was erased and then I am REALLY screwed up. Any hints/pointers that might help me with this would be greatly appreciated.

  2. ITASOR macrumors 601


    Mar 20, 2005
    EFI isn't stored on the HD, so don't worry about that.

    What format are you making the partitions? Make the OS X one HFS+ (Mac OS X Extended (Journaled)) and the XP one FAT (that's what the guides are saying).
  3. sabor thread starter macrumors regular


    Mar 17, 2006
    Ok, thanks for clearing the EFI part.

    My partitions are HFS+ for OS X (jorunaled) and FAT for XP. Anyhow, I went ahead and created just one partition (HFS+) and the OS X installer still says that it cannot install on the disk :confused:
  4. mrichmon macrumors 6502a

    Jun 17, 2003
    Sounds like you are using an APM partition table or a Windows MBR partition table rather than a GPT partition table as used on the intel Macs.

    Check Disk Utility under Partitions->Options.

    Edit: Yeah, this seems to be confirmed by the WinXP on Mac wiki. The OS X installer will refuse to install on the MBR+GPT partition table combination. Use Disk Utility to Erase using the "write zero" and you should be able to install OS X after the erase.
  5. grabberslasher macrumors 6502

    Aug 2, 2002
    This happened to me too - just re-partition the disk again. It automatically adds the 200Mb EFI partition anyway, so don't be worried about losing that.
  6. sabor thread starter macrumors regular


    Mar 17, 2006
    Hmmm...I can't find the Options under the Partition tab in disk utility. Where would I find to know what partition table I currently have?
  7. sabor thread starter macrumors regular


    Mar 17, 2006
    I have erased with Disk Utility the partition time and time again and the freakin' installer won't let me go ahead with the install. Any ideas?
  8. sabor thread starter macrumors regular


    Mar 17, 2006
    Here is the solution!

    Thanks to another forum post, I finally found the solution:

    "I've solved this problem starting an initialization with the erasing data flag checked (filling with zero) of the unique partition i've proviously created in the hard drive. Note that i didn't waited until the end of the process: click ignore. Next install osx on the partition or do anything you want."

    I just did it and it worked like a charm!! :)

    Thanks for the posts, appreciate them!
  9. chenwli macrumors newbie

    Mar 17, 2006
    Another way to do is using the disk utility from 1st OSX disk to wipe out the whole disk and format it with HFS (remove any exist partition), then you can partition again to whatever you want. I've met the same problem. I thnk it arises from the incorrect partition table or so. Don't panic, nothing wrong with your Mac!

Share This Page