Help "unimplemented trap"???

mymemory

macrumors 68020
Original poster
May 9, 2001
2,495
0
Miami
Ok, I just started my G4 and I got this:

Sorry, system error occurred
unimplemented trap
To temporarily turn off extensions, restar and hold down the shift key.

Ok, firs, I do not know why I'm getting this. I just started up the computer on OSX (I get the error with 9.2.2) and trashed the sys preference and replaced the finder icon, then I restarted under 9.2.2 and the message is there again.

2nd. why in hell Apple is telling me to start up agani with the extensions off? does that resolve the problem? No! so why am I getting such useless message?

Any way, if any body knows what the message is about please let me know, I'm in my holly Pismo right now.

Thanx.
 

Catfish_Man

macrumors 68030
Sep 13, 2001
2,579
1
Portland, OR
Well...

...make sure you're forcing it into X (which shouldn't have extensions you can turn off), and hold down command-s while rebooting. Run fsck, and type logout. If that doesn't work, then you've got problems.
 

Hemingray

macrumors 68030
Jan 9, 2002
2,913
25
Ha ha haaa!
Do you get the bomb when running Classic or just when you boot with OS 9?
Have you TRIED opening the extensions manager on OS 9 startup or does it bomb before it allows you to?
Have you installed any Classic programs recently?
Have you tried zapping the PRAM?
 

Sun Baked

macrumors G5
May 19, 2002
14,874
57
Do you run with all extensions on normally or do you turn everything you don't absolutely need off using the extension manager program?

Does it still give you a unimplemented trap error when booting into classic? or when you boot into OS 9 and turn all extensions off?

What programs, shareware, or hardware was recently loaded or upgraded?

Have you looked through the system folder for files that may be causing the problem?

(Search System Folder, Fonts, Control Panels, Extensions, Startup Items for files out of place - such as a font in the extensions folder)

Have yun Disk First Aid, fsck -y, and rebuilt the desktop to rule out a file system error? Zapped pram to rule out corruption there?
 

evildead

macrumors 65816
Jun 18, 2001
1,275
0
WestCost, USA
force OSX

You can hold down option while booting and see it will display a list of your Bootable disks/OS's. Take a look and see if your Mac can recognise OS X or not. If you can, pick OSX and let it boot. It could be you have a problem with OS9 and its stuck pointing at OS9 as the boot drive. I have had a problem like that before. I picked OS X as my bootdrive, rebooted, it came up in OS9 and crashed. Did the option thing and came up in OSX.
 

mymemory

macrumors 68020
Original poster
May 9, 2001
2,495
0
Miami
Thanx guys,

The problem is not with OSX, it is with OS 9. Yes, I get the bomb jst after the computer loads the first extention. I can start up with the extention manager but no matter how basic the set up is I get the same message.

Any way, I end up using the "G4 system restore disc" and sending folder from one partintion to the other. Now I have to update the system again.

Who know what generate that message, once each 3 or 4 years I get something like that.

Thanx any way.