HELP!! Updating iOS!

Discussion in 'Jailbreaks and iOS Hacks' started by ramnakhle, Jan 25, 2011.

  1. ramnakhle macrumors newbie

    Joined:
    Jan 25, 2011
    #1
    Hi! So I'm a complete newbie at these things so bear with me!
    Basically I have an iphone 3GS, unlocked, jailbroken (Cydia) running iOS 3.1 on firmware 5.11.07.

    I've been struggling finding information on how to update to iOS 4. I only want iOS 4+ Don't care if it's the absolute latest just need 4.0 whatever.

    My questions:
    0- Where can I find a glossary for all these terms? Baseband, firmware, unlock/jailbreak (difference) so i can get up to speed? I read forums etc.. but i don't get any of the stuff in there lol
    1- how can I do this update? Any step by step guides for newbies?
    2- What will I lose doing this? Settings, apps, jailbreak, will I need to unlock/jailbreak again? and how can i unlock/jailbreak?
    3- Thank you :D
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Open up cydia and look at the top of the page.
    Does it have SHSH's for any firmware versions listed?
     
  3. ramnakhle thread starter macrumors newbie

    Joined:
    Jan 25, 2011
    #3
    it says :
    SHSH: iOS 3.1.2, 3.1.3, 4.0, 4.0.1, 4.0.2, 4.1, 4.2.1+

    What does that mean?
     
  4. outphase macrumors 65816

    Joined:
    Jun 13, 2009
    Location:
    Parts Unknown
    #4
    You can update to any of those versions now and in the future
     
  5. ramnakhle thread starter macrumors newbie

    Joined:
    Jan 25, 2011
    #5
    OK Good.
    I downloaded pwnage tool 4.1.3
    I need to get an IPSW and found one.

    On this video: http://www.youtube.com/watch?v=ucybPkKbCWY
    the guy says that an iphone 3gs needs to be running 4.2.1 for the unlock/jailbreak to work. does that mean i have to update my phone on itunes before i use pwnage? I don't get it ... won't that freeze my phone?
     
  6. Applejuiced, Jan 25, 2011
    Last edited: Jan 25, 2011

    Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #6
    Yep, what he said above.
    You can update/restore to any of those firmware versions.
    I'd suggest to go up to 4.1 so you're not stuck with a tethered JB if you went to 4.2.1.

    No, dont follow any of that unless you're sure you have the old bootloader.
    Also dont install the ipad baseband, maintain your own.
    Just follow this:http://www.iclarified.com/entry/index.php?enid=13001
    When you get to step 6 make sure you select NO.
    HELL NO, not just no:D
     
  7. ramnakhle thread starter macrumors newbie

    Joined:
    Jan 25, 2011
    #7
    Ok great stuff. One more thing though. Sorry i wanna make sure i get all the facts right before i risk screwing up my phone :)
    I have firmware 5.11.07. Will this still work? and what is a bootrom?
     
  8. ramnakhle thread starter macrumors newbie

    Joined:
    Jan 25, 2011
    #8
    I don't get this:
    step 6: "You will now be asked if you want to update your baseband to the 06.15 version. If you are on 05.14 or 05.15 or higher you will need to do this to unlock. You do not need to do this for jailbreak only."


    I need to unlock as well right? Do i need to if i'm already unlocked before this process?
     
  9. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #9
    Read it slowly.
    If you're on baseband 05.14 or 05.15 or higher you need to update your baseband to unlock. Yours is on 05.11 so you're below that and dont need to update it to unlock. Pwnage will preserve your baseband so you can install ultrasnow from cydia when you're done to unlock.
    DO NOT CLICK YES on step 6 cause it will update your baseband to the ipads version and you will lose your GPS functionality and get into a whole different situation. Keep your baseband version the way it is and always use pwnage in the future if you need to upgrade.
     
  10. ramnakhle thread starter macrumors newbie

    Joined:
    Jan 25, 2011
    #10
    OK!

    Thanks! And sorry for my stupid questions :p
     
  11. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #11
    You're welcome:)
    Good luck.
    You might need to edit your hosts file to redirect to cydia server if you didnt already do it before.
    You will need to edit your hosts file located here – C:\Windows\System32\drivers\etc\hosts (Windows) or /etc/hosts (Mac OS X) and add 74.208.10.249 gs.apple.com to the bottom and save it. Now, when iTunes thinks it is talking to Apple, it is talking to Cydia instead.
     
  12. ramnakhle thread starter macrumors newbie

    Joined:
    Jan 25, 2011
    #12
    Ok you've guessed it. More nagging!

    1) I opened the terminal and typed the "sudo nano /private/etc/hosts" command. Got a prompt for password, I typed and nothing happens. Like I can't type in my password.
    2) I closed terminal and opened it again. Now it's blank. A blank window with nothing in it.

    WTF?
     
  13. ramnakhle thread starter macrumors newbie

    Joined:
    Jan 25, 2011
    #13
    pppheww!

    All Done.... 4.1 up and running. Thank you :)
     

Share This Page