Help! Upgraded Macbook RAM To 2GB Now Won't Boot Right!

TheRick

macrumors newbie
Original poster
Jan 26, 2005
25
0
When I bought my Macbook, I got the standard 512 MB of RAM. I recently purchased 2 GB of RAM from OWC. I followed the instructions and got it installed.

I then went to boot my Macbook and got the white screen with the gray Apple logo and the spinner. It never left that screen.

After trying a lot of things, I did a reinstall of Tiger using the Archive & Install option and that worked. I checked the System Profiler and confirmed that it saw the 2 GB of RAM. I did all of the Software Updates (including the 10.4.7 update) and everything seemed fine. I went to reboot later, and got the same white screen with the spinner and it never made it past it.

I again tried a lot of things. Sometimes I'd get the white screen with spinner, sometimes I'd get "verbose mode" (without initiating it) and would get errors about "com.apple.nibindd" spawning to quickly.

I found these instructions on how to clear caches/.plist files. If I booted into Safe Mode, followed those instructions, then rebooted, it was fine. However, the next time I rebooted, I'd get the same problems back.

Last night, I backed up everything and did an Erase & Install. Again, everything seemed fine. I rebooted a couple of times and everything seemed okay. I then went out and manually downloaded and installed the 10.4.7 Combo Updater. Now, I have the same problems again except now, I only get the errors about "com.apple.nibindd" spawning to quickly.

It would seem that 10.4.7 is what's causing my problems. However, I was running 10.4.7 before upgrading the RAM without any problems. Why is it different now? If the RAM was the problem, why would it boot fine in Safe Mode and work fine once after removing cache and .plist files?
 

knifegun

macrumors member
Apr 6, 2006
74
0
Are you sure your RAM is not defective? I installed new RAM and my machine would not boot up. Turned out it was a defective RAM module. I exchanged the module for a new one and my machine has worked fine since.


TheRick said:
When I bought my Macbook, I got the standard 512 MB of RAM. I recently purchased 2 GB of RAM from OWC. I followed the instructions and got it installed.

I then went to boot my Macbook and got the white screen with the gray Apple logo and the spinner. It never left that screen.

After trying a lot of things, I did a reinstall of Tiger using the Archive & Install option and that worked. I checked the System Profiler and confirmed that it saw the 2 GB of RAM. I did all of the Software Updates (including the 10.4.7 update) and everything seemed fine. I went to reboot later, and got the same white screen with the spinner and it never made it past it.

I again tried a lot of things. Sometimes I'd get the white screen with spinner, sometimes I'd get "verbose mode" (without initiating it) and would get errors about "com.apple.nibindd" spawning to quickly.

I found these instructions on how to clear caches/.plist files. If I booted into Safe Mode, followed those instructions, then rebooted, it was fine. However, the next time I rebooted, I'd get the same problems back.

Last night, I backed up everything and did an Erase & Install. Again, everything seemed fine. I rebooted a couple of times and everything seemed okay. I then went out and manually downloaded and installed the 10.4.7 Combo Updater. Now, I have the same problems again except now, I only get the errors about "com.apple.nibindd" spawning to quickly.

It would seem that 10.4.7 is what's causing my problems. However, I was running 10.4.7 before upgrading the RAM without any problems. Why is it different now? If the RAM was the problem, why would it boot fine in Safe Mode and work fine once after removing cache and .plist files?
 

TheRick

macrumors newbie
Original poster
Jan 26, 2005
25
0
Maybe, but why would it work fine in Safe Mode, work fine after trashing cache/.plist files (until another reboot), and seem to work fine until the upgrade to 10.4.7?

Also, I used the OS X install CD that came with my Macbook to do a hardware test and everything passed.

knifegun said:
Are you sure your RAM is not defective? I installed new RAM and my machine would not boot up. Turned out it was a defective RAM module. I exchanged the module for a new one and my machine has worked fine since.
 

TheRick

macrumors newbie
Original poster
Jan 26, 2005
25
0
Appears to be bad memory from OWC. Took out the two 1 GB chips and put back in the two 256 MB chip and all appears to be working now after multiple reboots.

I wouldn't have guessed that bad memory could have those kind of symptoms...
 

reflex

macrumors 6502a
May 19, 2002
721
0
TheRick said:
I wouldn't have guessed that bad memory could have those kind of symptoms...
Bad memory could have any kind of symptoms. Bad memory means that data isn't stored or read back correctly, so you get random data leading to random behaviour.
 

fistful

macrumors 6502a
Mar 29, 2004
892
0
Socan
You should try each GB separately as it could just be one that is faulty. If they're both faulty send them both back, if just the one you'll be able to use 1.25GB (1GB + 256MB) while you wait for the replacement RAM.
 

TheRick

macrumors newbie
Original poster
Jan 26, 2005
25
0
FistfulofAngst said:
You should try each GB separately as it could just be one that is faulty. If they're both faulty send them both back, if just the one you'll be able to use 1.25GB (1GB + 256MB) while you wait for the replacement RAM.
Isn't it bad to run Macbooks with mismatched memory? I thought I read or heard that somewhere...
 

shodekiagari

macrumors newbie
Jun 16, 2006
4
0
TheRick said:
Isn't it bad to run Macbooks with mismatched memory? I thought I read or heard that somewhere...
I don't think it's bad so much as it is you're not supposed to get as good graphics performance. Though, 1.25 gigs is probably better than 512 no matter what...