Help: Users Folder content gone

Discussion in 'Mac Basics and Help' started by greenfrog5, Nov 30, 2010.

  1. greenfrog5, Nov 30, 2010
    Last edited: Nov 30, 2010

    greenfrog5 macrumors newbie

    Joined:
    Nov 30, 2010
    #1
    PROBLEM: Computer can't boot, and the content of the /Users/aaron/ folder seems to be missing (or invisible?) when booted from an external clone.

    Intel Macbook Pro (older), with OS X 10.6

    Sorry, a bit long to avert initial follow-up questions:

    A week ago, my computer froze and I had to hard-shut it off. Then, it wouldn't boot past the Apple-logo screen. Disk Utility couldn't Verify/Repair it (said backup and reformat). Disk Warrior said the same. I had a recent TM backup, and SuperDuper clone, so I formatted and clean-installed Snow Leopard, then migrated my TM data.

    Worked fine for a week, had 40GB+ free space. Then, this weekend, it says 'Startup disk getting full' and has 1GB of free space. I didn't think twice about it at the time (b/c I occasionally/accidentally do fill my disks) but now thinking, it still should have still had 40GB free. I shut it down, which may have taken a bit longer than normal.

    When I go to boot it up again, it won't pass the Apple-logo screen again. Eventually it boots past, but it goes to gray screen, then to the Apple space-flare screen (star background with swirly colors in the middle - this screen sometimes comes up when starting-up/shutting-down when OS X gets confused). The mouse comes on, and everything stops there.

    Same thing as before with Disk Utility (cannot repair, backup and reformat). Disk Utility Repair Disk: 'Invalid Extend Entry' SMART: verified. Disk Warrior won't currently open from my bootable clone (corrupt preference file, I haven't messed to fix it yet). My main concern, is that looking into my /Users/aaron (home) folder on the corrupt drive to pluck a few recent file, it is EMPTY! The drive says it has 40GB free (which is what reminded me it shouldn't have filled after a recent fresh install/migration). WTF?!?

    Again, I have a recent TM and fairly recent SuperDuper so I'm not panicking, but am suspecting I need to replace the HD? Again, fine, since I've been planing to upgrade it, but I'm concerned with what HAPPENED? Did I do something wrong? Is it just a coincidental drive-failure, and a 'glad I had a backup,' buy a new drive? Are there steps to recover the data (assuming I didn't have recent backups, just curious, for worse cases)?

    Thanks
    Aaron
     
  2. greenfrog5 thread starter macrumors newbie

    Joined:
    Nov 30, 2010
    #2
    Reading more around the web, this thread seems similar to my problem, but I'm having problems trying the solution:

    http://discussions.apple.com/thread.jspa?threadID=2132433&start=15&tstart=0

    When I try to run sudo xattr -d ... I get sudo: xattr: command not found. I've tried everything with the paths, with no success. I have checked and both sudo and xattr exist in /usr/bin/ - but I don't know what the problem is. I've also noticed that sometimes I can type "cd /Volumes/Ma [TAB]" and it will auto-fill Mac-"intosh" to put "Macintosh\ HD". Other times it won't, and makes me type it all out. Either way, it DOES allow me to switch to the drive.

    Is it likely the Users/aaron data isn't showing (but still exists) because of the FinderInfo problem discussed in the above thread?

    Thanks
    Aaron
     
  3. greenfrog5 thread starter macrumors newbie

    Joined:
    Nov 30, 2010
    #3
    UPDATE: Improved, but not fixed

    With any luck, by tomorrow, I'll have answered ALL of my own questions, and be back up and running smoothly.

    I resolved the Disk Warrior preference file issue, and DW was able to rebuild and replace the drive structure. This allowed me to view my /User/aaron content (it is still THERE!) - good.

    It then required me to login (which I had disabled before), and wouldn't accept my old password. I used the OSX CD to reset my password, and now the computer almost boots. It seems to be getting hung-up after showing my desktop BG and the menu bar, but before loading the Dock, etc. Just goes to spinning beachball while loading things, and never finishes.

    I'm going to SuperDuper the somewhat repaired drive to a spare HDD tonight, and hoping Repair Permissions and Repair Disk will improve the issue to allow full startup.

    How can I tell if the HD is going bad? SMART says fine. DW has something to check the hardware? Or TechTools?

    Thanks
    Aaron
     
  4. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #4
    TechTool Pro does several hardware checks, yes. Hopefully, it will tell you what the problem is. Good luck!
     

Share This Page