Help using a mad catz xbox 360 wired controller

Discussion in 'Mac Accessories' started by Something915, Mar 7, 2010.

  1. Something915 macrumors newbie

    Joined:
    Mar 5, 2010
    #1
    I have a MacBook Pro with OS X 10.5.8 and I have downloaded the Xbox 360 controller driver from TattieBogle. When I go to system preferences, click on "Xboxo 360 Controllers" from the under section, then click on device, there are no options but no devices found. I have also downloaded USB Prober and it does find my controller. So how do I get Pref360Control to find my controller?
     
  2. apraetor macrumors newbie

    Joined:
    Apr 24, 2010
  3. penter macrumors 6502a

    penter

    Joined:
    Jun 15, 2006
    #3
    didn't work for me...
    I think I typed the code into terminal the wrong way...
    do you mind posting exactly how to type the commands into terminal?
    am i supposed to replace the old ktext file with the new ktext file?
     
  4. mgarman14 macrumors newbie

    Joined:
    Dec 3, 2010
    #4
    penter and something915...

    if you haven't gotten it working yet, i was having a hell of a time as well until i used this command:

    right before the "sudo kextload 360Controller.kext"

    type: cd /system/library/extensions

    I am a newbie at all of this stuff, but this worked for me.
     
  5. mizzles macrumors newbie

    Joined:
    Feb 26, 2011
    #5
    I hate to point this out apraetor, but your tutorial is for Snow Leopard. The OP is running Leopard. I too have been exhaustively trying to get my MadCatz 360 Controller to work to no avail. Please post with a relevant link if possible.

    Again I stress that it should be worked for Leopard (Mac OS X 10.5.8). I think that might be the issue many of us who are using Leopard are running into.
     
  6. apraetor macrumors newbie

    Joined:
    Apr 24, 2010
    #6
    mea culpa.. my instructions were for 10.6 not 10.5.. but here's the fix

    Oh, good point.. sorry. The commands for terminal are different in 10.5 -- instead of kextload the command you need to use is kextutil. So replace the final step in terminal with:
    • sudo kextload 360Controller.kext
     
  7. Ciffy macrumors newbie

    Joined:
    Dec 18, 2011
    #7
    Just want to add the instructions in the first reply worked for me with no changes. I'm on 10.5.8 with a MadCatz controller from Target (not sure of the model). Thanks a TON for the instructions as I never would have figured that out myself!

    Now it's time to play my humble indie bundle games.... jamestown here I come!!!
     
  8. dragonfax macrumors newbie

    Joined:
    Jul 20, 2012
    #8
  9. esp78g macrumors newbie

    Joined:
    Mar 4, 2013
    #9
    Hi, im running OS 10.7.5. is there anything i need to do differently?
     
  10. Vyv macrumors newbie

    Joined:
    Mar 20, 2013
  11. Vyv macrumors newbie

    Joined:
    Mar 20, 2013

Share This Page