Help w/Safari - GONE, so d/l new version, but need help on next step

Discussion in 'Mac Apps and Mac App Store' started by connieran, Dec 31, 2011.

  1. connieran macrumors newbie

    Joined:
    Mar 8, 2011
    #1
    Ok, here's my story. I have an iMac desktop computer, OsX 10.6.8 snow leopard. All of a sudden, I do NOT have "Safari" anymore? no reason why? I am the only one on the computer. Said something about 'cannot find and may be missing important resources' or something? It was there all along, then GONE! So.... I tried to download it from Apple site, and it said I needed a more updated version of OsX. So, I got the new version of that also (thru 'software updates'.. which I've been meaning to do anyway.) So.. then I could finally download the Safari 5.1.2, but now it just gives me a little picture of a package under "applications" which says "Safari 5.1.2 snow leopard pkg." So I click that... and it brings me to the "Welcome to the Safari Installer" page... and I did that too... all the way thru and downloaded it and re-started computer, as instructed. But still do NOT see my "Safari" icon. ONLY see the same little 'installer box' thing, in Applications. When I click it, it asks me to d/l it ... but I already did that? I am not really good with this sort of thing, so someone please tell me what I'm doing wrong? i just want to have my Safari back. I have Firefox in the mean time, but I like Safari! 1-- What happened to it in the first place? and 2 -- How can I click it to make it appear when I don't know where it is? Did I not download it the right way? HELP. and thanks
     
  2. robgendreau macrumors 68040

    Joined:
    Jul 13, 2008
    #2
    Do a search in Spotlight on the word "safari.app" and look for the results and then click "show all in Finder." When the window opens, you should see "Safari" in the results. Highlight it, and look at the bottom of the window and that should tell you where it is. Or right-click and choose "open enclosing folder."
     
  3. connieran thread starter macrumors newbie

    Joined:
    Mar 8, 2011
    #3
    It says "No results found"???

    Thanks so much for taking the time to reply to me. I did what you said and it says "No results found"??? I am so confused of how it went away in the first place, and now I downloaded it from Apple site, and followed the directions and it said "download complete"... but NOT here?? I normally know how to do all this stuff, and feel silly now cuz I am so stumped about how it happened and what to do? ANy more suggestions? thanks
     
  4. connieran thread starter macrumors newbie

    Joined:
    Mar 8, 2011
    #4
    Help! Still no Safari, BUT other users have it on same computer!???

    I still cannot get Safari .... and the weird thing is, my son, daughter, and husband all have it on this same computer, but under their own user name. ??? and one other thing... not sure why, but cannot click "restart" computer or "shut down". When I type in my name and p/w, it just sits there and nothing happens. I had to press the on/off button to turn off. ANyone have any ideas or can help me? Thanks
     
  5. connieran thread starter macrumors newbie

    Joined:
    Mar 8, 2011
    #5
    Found solution! fixed!

    for anyone else who may be searching and need a solution to this, I found the solution. I did some searching and finally found someone who said to "repair permissions" on my operating system, and sure enough, I did that, and Safari is back! Also, on a side note, a few pics that were NOT showing up in my iPhoto (after I upgraded to iLife '11 software) showed back up again! just wanted to update this.
     

Share This Page