Help w/wireless router/printer MBP - Please

Discussion in 'Mac Accessories' started by dcains, May 6, 2007.

  1. dcains macrumors regular

    Joined:
    Mar 27, 2007
    #1
    Hi Group:

    Here's my hardware:
    New MBP 2.33/2GB/15"
    2 old Dell WinXP laptops
    Netgear WGR614v6 wireless router
    Netgear PS 101 print server (hardwired to the router and parallel port on printer)
    Epson Stylus C88+ printer

    No trouble getting the two XP laptops to print wirelessly, for the last year, and they still work great.

    My new MBP connects to the router, and has internet access. I was also able to connect to the print server by entering its IP address into the Mac's LBP print function. But, I can only select "generic postscript printer" from the list of printers. OS X 10.4 doesn't have the Stylus C88+ listed, and I'm not sure the Epson site has the correct driver, either, as they don't mention Macs with Dual Core Duo processors. I installed the Epson driver anyway, and still can't select it. MBP printing does work using the "generic postscript printer" selection, but that's not going to cut it for the long-term, as I can't control the printer settings. And, the Epson site only mentions Mac C88+ driver support for USB printing, but the print server is connected to the parallel port on the printer (printer has both USB and parallel, print server only has parallel). Netgear support, from past experience is about the worst, and Epson's seemingly is better, but they're not so Mac informed. This is my first Mac, so I'm not much help to myself, obviously.

    So, what's my best course? A) try and work with what I have, if someone can offer simple instructions B) buy a different print server C) buy a new wireless router with USB printing built-in

    I'm leaning toward option C, if I can do it for <$100, and it will work properly with the Epson printer (which I really want to keep). Thanks in advance.

    Regards,

    Dean
     
  2. Reflow macrumors 68000

    Reflow

    Joined:
    Mar 30, 2005
    Location:
    NJ/PHL
    #2
    Hi Dean,

    First of all you need the right print driver. Here is the place to get it. What you need to do now is download the driver and us IP printing with the IP address of the print server and you should be good to go
     
  3. dcains thread starter macrumors regular

    Joined:
    Mar 27, 2007
    #3
    Thanks very much to the pointer to the recommended driver, which I was able to download. Unfortunately, I'm way too much of a Mac newbie to know what to do with that file, which has an ".rpm" suffix. What's the next step?

    Also, it does appear that OS X 10.4.x does include a similar (perhaps slightly older version of the GIMP driver included - Gimp-Print v5.0.0 beta2), which I did try using IP printing, but got no output from the printer.

    Sorry for being so clueless about Mac's, but I could sure use some continued advice on what to do next. I will have another print server, a Buffalo Technology USB, by Wednesday, so that may also help, if I'm not up and printing by then. I'm wondering if the Netgear PS101 printer server, because it's parallel, is part of the issue. The Epson Mac driver is only for USB printing, and it works great if I hard wire the printer to the MBP. Thanks in advance, again.
     
  4. Reflow macrumors 68000

    Reflow

    Joined:
    Mar 30, 2005
    Location:
    NJ/PHL
    #4
    Did you download the right driver? Here is the one I found which is a .tar.gz file which should work on your MBP. The one above that is for PPC which you have an intel machine so don't us that one
     

Share This Page