Resolved Help: Website not available...

Discussion in 'Mac OS X Server, Xserve, and Networking' started by MandiMac, May 5, 2016.

  1. MandiMac macrumors 6502

    Joined:
    Feb 25, 2012
    #1
    Hey all,

    I'm planning to host a website with my own Mac mini. So I tried to get OS X Server up and running, but the website only shows up to be available within my own network.

    I'm running El Capitan, I changed under DNS from the already bought domain to the IP that I get from OS X Server, and even the guys from the domain company think that I messed up on the OS X Server part. (Files are attached.)

    But I don't get it: The firewall is off, the domain shows to the IP I get from Server, and still nothing goes online. What do I do wrong?

    Please fire away! :)

    Much appreciated,
    Fred
     

    Attached Files:

  2. DJLC macrumors 6502a

    DJLC

    Joined:
    Jul 17, 2005
    Location:
    Mooresville, NC
    #2
    Is your router configured to forward incoming traffic from the outside to your server? And what class of uplink do you have? Some residential ISPs block such traffic.

    I'd look toward a firewall / router misconfiguration.
     
  3. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #3
    Are you sure that you don't need to forward the public IP address and/or port to your server in your router? and do you know if your ISP allows web hosting?
    I think DJLC is on the right track above.
    Also, be aware that there's no point in masking your IP address in the above image. If we know your domain and hostname, we know your IP address. That's a risk you have to take if you're hosting a public website, though in reality, knowing an IP address is not a significant risk.
     
  4. MandiMac thread starter macrumors 6502

    Joined:
    Feb 25, 2012
    #4
    Hi and thanks for the reply!

    The router is a Time Capsule, so I figured that Server would do all of the config itself. Fun fact: Little over one year ago, it worked without a hiccup.

    Firewall is off, the only thing that's changed is the modem from the ISP, I guess that's where the problem is. Now I have to figure out how to access this modem, should work via IP I guess...
    --- Post Merged, May 6, 2016 ---
    Hi and thanks for the reply,

    I thought the router (Time Capsule) would get config'd accordingly when I start the Websites option in Server. And the ISP hasn't changed since the last time when it worked flawlessly, but the modem has. You guys pointed me towards the solution, I guess, but I can test it only tomorrow. I'll keep you updated and thank you so far!
     
  5. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #5
    Man I hope you doing this on a business account or your ISP will block home web serving!
     
  6. DJLC macrumors 6502a

    DJLC

    Joined:
    Jul 17, 2005
    Location:
    Mooresville, NC
    #6
    So I did some testing in a free moment, and now I'm thinking it may actually be something with your OS X config or your ISP.

    A port scan on your IP shows port 80 open. Attempting to load your domain name, computerfinder.info, results in nothing (doesn't load, no errors either). Attempting to load your IP address, however, results in a Gateway Timeout error.

    So either something in OS X Server isn't allowing connections when using the domain or external IP, or your ISP is blocking traffic. I'll wait for someone more experienced than me to give input on that...
     
  7. Geeky Chimp macrumors member

    Joined:
    Jun 3, 2015
    #7
    I can ping and traceroute to your Router so I would also confirm DJLC's post above that it is either the OSX Server Firewall, a Port Forwarding issue or your ISP could be blocking port 80.
     
  8. MandiMac thread starter macrumors 6502

    Joined:
    Feb 25, 2012
    #8
    Hi guys,

    you were right: The modem blocks the 80 port entirely with no chance to change that. That is the price for moving up to another tier ;)

    Thanks to all and have a nice day!
     

Share This Page