HELP - Wifi "Connection Timeout" on new MBA with Lion

Discussion in 'Mac OS X Lion (10.7)' started by gswilder, Jul 28, 2011.

  1. gswilder macrumors regular

    Oct 3, 2007
    I just bought a new Macbook Air, 13" 1.8ghz with Lion preinstalled (latest model) from our local apple store.

    I cannot get the MBA WIFI to connect to my Wireless N router (Netgear WNDR3700) at 5ghz (dual band). Using WPA2-PSK (AES). When I try to join, I get "connection timeout".

    Some other facts to consider....

    The MBA connects fine to the 2.4ghz part of the router using WEP no problem.

    The MBA connects to another Wireless access point at 2.4ghz using WEP just fine.

    I have a one month old 15" Macbook pro, that I just upgraded from SL to Lion. It connects fine to the 2.4ghz and 5.0ghz wireless routher. Both before and after upgrading to Lion OSX.

    I have several windows PCs that all connect to the 5ghz fine.

    I have done a lot of searching on this problem, but cant find a solution. Again, my 15" MB Pro (with lion) works just fine and always has. Before and after upgrade of OSX.

    Of course, I have tried all the standard stuff. Rebooting MBA, wireless router. Changed my WEP and WPA keys, latest fireware, etc.

    Any suggestions?

  2. soroshtavakoli macrumors newbie

    Aug 5, 2011
    Me too!

    Have the same problem, can't connect to a whole bunch of wifi networks. Can't even connect to my iPhone teethering...

    I have a new MBA with Lion on it.
  3. jpalley macrumors newbie

    Aug 5, 2011
    Wifi "Connection Timeout" with Mac Mini

    I'm having the same connection timeout issue. The Mac Mini will find the network at random, and later drop the connection just as randomly.

    I'm sure it's a software bug. My Mini connects fine with Snow Leopard running, and I am 100% sure that my network is stable; all other devices can connect just fine. I had a similar issue with my bluetooth. The computer disconnected twice from my Apple trackpad. First time that happened too.

    I called Apple Support about eight times, and we tried everything, and nothing worked. I eventually reinstalled Snow Leopard.

    Love Lion, but I love connecting to the internet even more. Very disappointing. I hope Apple comes up with a patch soon.
  4. stuartmack1974 macrumors member

    May 9, 2011
    swansea, wales, uk
    Yep same here - spend over an hour with apple and no joy. Can connect to secure networks but not open ones.
  5. gentlefury macrumors 68030

    Jul 21, 2011
    Los Angeles, CA
    2011 11" macbook air, no problems at work or at home.
  6. Makaveli6103 macrumors 6502

    Jan 31, 2009
    Kansas City, MO
  7. astormridr macrumors newbie

    Aug 25, 2012
    Change your settings bypass!

    I'm not much of a technical dude, but I was just now having this problem with my own router and changed the settings to a password free undetectable or unbroadcasted SSID setting. Won't work for everywhere, but at home is a quick fix.

Share This Page