Help! WiFi disconnects on waking from sleep if bluetooth is on

Sid-R

macrumors member
Original poster
Dec 8, 2010
45
0
My maxed Macbook air 11 2012 upon waking up from sleep it takes either too long to reconnect to home wireless or just waits for me to select my wireless from the drop down list.
This issue only shows up only if I have my bluetooth turned on. Turning off bluetooth fixes the issue.
I have tried deleting wifi setting and resetting, setting service order to give preference to wifi over bluetooth but no luck.
It is a major annoyance as I use bluetooth speakers, keyboard. Also I have been having this issue since Mountain Lion, Mavericks did not fix it.
Anyone else seeing the same problem or any solutions.
Thanks
 
Last edited:

lo100469

macrumors member
Sep 26, 2013
72
9
Brussels
Maybe you did that already but if not:
Go to "open network preference", on the bottom left corner you have an icon looking like a gear, near the + and - signs. Click on it and choose "service order".
Once there make sure wifi goes before BT

Ignore my post you tried this already....
 

Sid-R

macrumors member
Original poster
Dec 8, 2010
45
0
Thanks for the reply. Tried that already. No Luck
 

BulkHedd

macrumors 6502
Nov 13, 2006
492
14
I'm having a similar problem but I don't know if it has anything to do with Bluetooth or not.

Mine is a 2010 13" MBP. Just a couple of weeks ago I installed a 256GB SSD and did a clean install of Mavericks. I have TeamViewer installed so I can access it from work (I know I could just bring it but I don't need to access it all that often). Since the fresh install of OSX I started noticing that when I would open TeamViewer from work it shows my MBP offline. Today I went home for lunch and noticed that the WiFi emblem on the menu bar just showed the outline.

Frequently after waking from sleep the WiFi seems to be turned off as well.

I really didn't have this problem before the SSD upgrade.