Help! Win 8 x64 on MBP early 2008 audio not working

Discussion in 'MacBook Pro' started by ptolemywasright, May 25, 2013.

  1. ptolemywasright, May 25, 2013
    Last edited: May 25, 2013

    ptolemywasright macrumors newbie

    Joined:
    May 24, 2013
    #1
    Help! I upgraded to Win 8 x64 the straight way from Win 7 x64 from within Windows after already having Win 7 x64 on Bootcamp. I have an early 2008 Macbook Pro (I realise these are officially not supported, but others have had no issue getting audio, just issues getting Bootcamp 5 to run/install). Bootcamp 4 nor 5 installs, but all drivers are working fine and working EXCEPT audio. No speakers, headphones, microphone. I'm using MacDrive 9 to access my HFS+ partition, so I don't really care about Bootcamp too much, I just want the audio drivers to work.

    Does anyone have, or have a link to, the audio driver(s)?! Intel High Definition Audio. No idea why it didn't pick up the Win 7 driver and use that.

    All my Win 7 files are still on there, put away in a folder named 'Windows.old'. All the system files, everything. So my audio drivers must be there? Can anyone tell me what I'm looking for exactly and how I go about replacing the currant useless ones? Thanks a ton!

    MBPro 4,1 (early 2008 pre-unibody) - yep 4,1 is the model identifier (not 3,1)
    500GB SATA / 6GB DDR2 667 / NVidia GeForce 8500GT

    OS X Mountain Lion + Win 8 x64 Pro dual-boot (Bootcamp still managing that)
     
  2. ptolemywasright thread starter macrumors newbie

    Joined:
    May 24, 2013
    #2
    Ok I got inside BootCamp 5 and installed Realtek HD Audio manually (even though that isn't my soundcard), this works. I installed all Apple Bootcamp drivers manually, seemingly successfully, but on reboot almost none work (Apple keyboard, Screen light-sensor, etc). Any ideas? Bootcamp 5 as a whole still won't install on a machine as old as mine :(
     

Share This Page