iPhone [Help] Winterboard error "There was an error loading the preference bundle for winter

Discussion in 'Jailbreaks and iOS Hacks' started by becast, Feb 25, 2014.

  1. becast macrumors member

    Joined:
    May 8, 2013
    #1
    Phone: Iphone 5S 64Gb 7.0.6 Jailbreaked.

    Yesterday I was on 7.0.4 jailbroken and winterboard did not have any problems, same as other apps.

    Today I updated my phone to 7.0.6 and then jailbreaked again with evasi0n 1.0.6

    Now winterboard 0.9.3911 is not loading the themes and when I go to settings>Winterboard an error appears saying "there was an error loading the preference bundle for winterboard".

    I tried to fix it by uninstalling and reinstalling winterboard, cydia substrate and substrate safe mode in severall ways. I did reboot and respringed.

    And winterboard does respring by itself when I select a theme and exit winterboard.

    The only tweaks I have installed are winterboard, ifile and activator.

    All I can think of is that winterboard not compatible with 7.0.6?

    does someone have problems with winterboard on your 5S 7.0.6 devices?

    So if someone know what is happening and how i can resolve it. I would appreciate it.

    Thank You
     
  2. DaBeast macrumors newbie

    Joined:
    Feb 26, 2014
    #2
    Same

    Same here Bro i tried everything to solve this Problem i cant im thinking its just that we updated to 7.0.6 Im not Sure hoping for an update :mad:
     
  3. bigjnyc macrumors 603

    bigjnyc

    Joined:
    Apr 10, 2008
    #3
    Having the same problem when looking in Cydia I can only find Winterboard version 0.9.3911 but there is a message that says ARM64 devices are only compatible with version 0.9.3912 or higher..... however I cant find any other version in cydia. Just when I was loving my ayeris theme :(
     
  4. wacky4alanis macrumors 6502a

    Joined:
    Mar 18, 2009
    #4
    There is a whole thread on this bug somewhere... Use iCleaner to clear out your repo data, and then everything will reload properly. Here's what you do:
    1. install iCleaner (free)
    2. Turn off everything in iCleaner
    3. Turn on the "Cydia Sources" switch
    4. Hit "Clean" on the top right

    After that, your repo data should reload and everything should start working. it worked for me anyways... I was immediately able to install the latest versions of Cydia apps instead of all the ancient crap that had been showing up.
     
  5. BumpyFlatline, Feb 26, 2014
    Last edited: Feb 26, 2014

    BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #5
    Yes this is working for a lot of people.

    But I'm curious, how can you install iCleaner (along with all its dependencies) without any repos loading, and no OpenSSH or afc2add installed? How are people getting around this?
     
  6. wacky4alanis macrumors 6502a

    Joined:
    Mar 18, 2009
    #6
    It's not that there are no repos showing - they just show older versions of stuff. Apparently whatever version there was of iCleaner it found was good enough to do the job. I DID get a warning that it wasn't compatible with 7.0.6, but it worked anyways. I just unchecked everything except "Cydia Sources" to avoid other problems in case there was some sort of incompatibility.
     
  7. becast, Feb 26, 2014
    Last edited: Feb 26, 2014

    becast thread starter macrumors member

    Joined:
    May 8, 2013
    #7
    Ok, people, I solved it but I had to install every tweak one by one but of course by queing each tweak in cydia to install faster.

    I do recommend install winterboard first and reboot before installing the tweaks you had before, after using iLEX R.A.T. (iOS 7)

    This is what I did:
    1. I installed iLEX R.A.T. (iOS 7) from repo: http://cydia.myrepospace.com/iLEXiNFO/
    2. Opened Ilex rat.
    3. I tapped ilex R.A.T inside the app ( this will remove all cydia tweaks and dependencies)
    4. waited to do its thing.
    5. Reinstalled and tested winterboard without problems.
    6. Install all tweaks over again by queing .
    7. everything working again.

    I was thinking about using icleaner but for some reason I was afraid to use it for cleaning cydia stuff.

    The problem was in my iTunes backup because each time I did a backup restore after DFU restoring my phone and jailbreaking, winterboard never worked.

    I used appinfo to make a list of all I had installed to install it faster.

    I did not want to use pkgbackup because the problem might be backedup also? not sure

    This did work for me, but it does take more time I think.
     
  8. Jman13 macrumors 68000

    Joined:
    Aug 7, 2011
    Location:
    Columbus, OH
    #8
    I solved it with icleaner. Clear the Cydia sources, refresh changes, install winter board and updated substrate, etc.
     
  9. Maverik3 macrumors 6502

    Joined:
    Mar 13, 2012
    Location:
    Meridian Idaho
    #9
    Thank you so much!!!' It worked perfect now everything works as it should#
     
  10. ajamesk macrumors newbie

    Joined:
    Feb 26, 2014
    #10
    Yay that worked! Thank you!!

     
  11. Trucker5024 macrumors newbie

    Joined:
    Feb 28, 2014
    #11
    ICleaner worked perfect for me also, just had to go to packages and reload. Awesome thanks!!!
     

Share This Page