Help! Wireless printing problems

Discussion in 'Mac Accessories' started by iaddict, Jun 14, 2008.

  1. iaddict macrumors 6502

    Joined:
    May 15, 2007
    #1
    I am trying to print to an Epson 3000 from my iMac. I have a Netgear wireless print server set up with 2 printers connected to it: brother MFC465 and the Epson 3000. The Brother is connected via an ethernet but the Epson through a usb connection. I can print to the Epson if I connect it to the computer but it won't print once I connect it to the router. The Brother, however, does print. So, I know that my computer is communicating with the router, I just can't figure out why the Epson won't. Can anyone help me?
     
  2. Blue Velvet Moderator emeritus

    Joined:
    Jul 4, 2004
    #2
    I had a tremendous amount of problems getting my Samsung printer to work with Leopard and an Airport Extreme. I tried everything I could think of but nothing...

    But, what did work in the end without fail was setting up the printer using an IP address as described in this thread on Apple's forums. It wouldn't hurt to give it a try even though your printer is an Epson.
    http://discussions.apple.com/message.jspa?messageID=6728493#6728493
     
  3. iaddict thread starter macrumors 6502

    Joined:
    May 15, 2007
    #3
    Thanks

    I will try that. Thanks for the response.
     
  4. iaddict thread starter macrumors 6502

    Joined:
    May 15, 2007
    #4
    Nope, still doesn't work

    The bad thing is I had it working for awhile then another computer on my network wasn't able to print. Somehow I deleted the printer in my system preferences and it's been trouble ever since.
     

Share This Page