Help with 0.5ghz iMac

Discussion in 'iMac' started by Nipz, Jan 26, 2009.

  1. Nipz macrumors 65816

    Nipz

    Joined:
    Nov 1, 2006
    Location:
    UK
    #1
    Hey all,

    My aunty as an original iMac with a .5ghz and about 128MB of ram that all of a sudden as gone funny. The Mac it self works perfect (even though it must b 10 years old) but the screen has gone purple and really dark. You can still see it if u sit in a dark room.

    What are the possible problems? Is this it for it now?

    She wants to get a MacBook anyway so its really the end of the world. Just a shame to see this amazing machine on its last legs.

    Thanks

    Ben
     
  2. nutman macrumors regular

    Joined:
    May 19, 2006
    #2
    probably the crt going bad. time to get a new mac. crt monitors can leak the gas that makes the screen colorful.
     
  3. Nipz thread starter macrumors 65816

    Nipz

    Joined:
    Nov 1, 2006
    Location:
    UK
    #3
    Thanks for that. I figured something was up but didnt know the technical stuff!
     
  4. edgew8 macrumors regular

    edgew8

    Joined:
    Dec 8, 2008
    #4
    The good news is you can get eMacs for a song on ebay that run a lot faster than those original iMacs
     
  5. Pixellated macrumors 65816

    Joined:
    Apr 1, 2008
    #5
    Is there anything magnetic near it? External speakers? Headphones even...
     
  6. MacVidCards Suspended

    Joined:
    Nov 17, 2008
    Location:
    Hollywood, CA
    #6
    You might also check the Boot ROM.

    The slo load iMacs did a weird thing if you installed Tiger and hadn't updated the ROM. They would end up with buggered up video until you updated ROM.
     

Share This Page