Help with Apple Alum Wireless Keyboard, lost vol up/dwn function

Discussion in 'Mac Accessories' started by NCRAW, Jul 1, 2009.

  1. NCRAW macrumors newbie

    Joined:
    Nov 17, 2007
    #1
    Hi Guys,

    Another frustrating problem started occuring in the past two days with my apple wireless alum keyboard. I lose all the F button functions like volume up/down, mute, forward track reverse and eject. This occurs if i restart the comp or come put of hibernation (there still the problem with the mouse sometimes freezing when comin from hibernation) or when i switch from mac os to windows. This problem occurs in windows (XP). Im not sure what happened but i recall windows had an update a couple of days ago!!

    I checked if there is an update to sort out the bluetooth issue but nothing new.

    Anyone having the same problem. Really annoying to shutdown and turn on the comp again just to get the buttons working again. Any help will be much appreciated.

    Comp is iMac 24" Alum 2007 sep build.

    thanks
     
  2. rkdiddy macrumors 65816

    rkdiddy

    Joined:
    Mar 19, 2008
    Location:
    OC Baby!
    #2
    Going off memory here - but I thought the volume keys only work with iTunes open in XP??? Is that correct.

    It is possible the XP update killed it - but I doubt it. You may want to install keytweak and just remap the keys to do what you want them to do in XP.
     
  3. NCRAW thread starter macrumors newbie

    Joined:
    Nov 17, 2007
    #3
    Vol buttons work to control audio volume similar to what u get under Mac OS so u could be right that the windows XP update killed it. The annoying thing that all goes back to normal after u do a shut down and a restart, and thats only sometimes. Even a restart wont fix the problem. Yesterday after posting i decided to run bootcamp 2.1 again and basically reinstalled all the drivers (dont think i can select drivers myself). All is ok but i will wait a few hibernations before i make judgment.

    By the way, where on apple website can i get the latest drivers for the iMac 24"?
     
  4. NCRAW thread starter macrumors newbie

    Joined:
    Nov 17, 2007
    #4
    Problem surfaced again, this time after restarting!! not sure what to do, any help would be really appreciated. I think its the windows update as now the wireless connection takes ages to load up at after start up!!

    Helpppppppp i hate not having control over audio or brightness!! and no eject button
     

Share This Page