Help with ATV2 (possible brick after JB)

Discussion in 'Apple TV and Home Theater' started by osufan1984, Feb 15, 2011.

  1. osufan1984 macrumors newbie

    Feb 15, 2011
    I followed the steps to jailbreak the ATV2 using GP RC6, but about 5-10 seconds after it started jailbreaking GP force closed. I let the ATV go for a few minutes before relaunching the application and trying again. After relaunching, I followed the steps and it went through the jailbreak and said complete. I gave it some time after saying complete before unplugging the USB and plugging in the HDMI. After this I saw an apple logo on the TV and a blank screen before it came up with the itunes logo and a USB cable. I tried restoring the ATV, but itunes seems to get hung up on the last 2% of the status bar where it says restoring ATV software. Does anyone have any suggestions or am I just SOL? Thanks in advance

  2. earthmonster macrumors newbie

    Aug 5, 2010
    Assuming the AppleTV is similar to the iPhone then it is extremely hard to actually "brick" it through the act of jailbreaking. A "brick" more often than not requires a hardware failure, which usually prompts an error in iTunes. And it doesn't sound like there was an iTunes error.

    Try connecting your AppleTV to your computer with the micro USB. Do not connect the AppleTV to an outlet.

    Hold "down+menu" for ~7 secs. You should see the light change the blink pattern, release the buttons when you do.

    Immediately hold "menu+play for ~7
    secs. Again, the blink pattern of the light will change, release the buttons.

    Your computer should detect the AppleTV in DFU mode and start iTunes, it it wasn't already running.

    Try the restore now.

    FWIW when I jailbroke my AppleTV with Greenpois0n I used the aforementioned method to get into a "jailbreakable state" and ignored the GP directions.

    Also I can't stress enough that after it says "jailbreak complete" you wait. Go get something to drink, hit up the bathroom, just do something to let it finish before hitting "quit". The first time I thought I waited long enough before hitting "quit" only to find out I didn't wait long enough. I re-jailbroke and this time I made sure I waited longer. I may be mistaken but I feel like the led on the AppleTV will be flashing when GP says "Jailbreak Complete" and I went and did someting in another room and when I came back the light was steady. When I hooked it up it was successfully jailbroken.
  3. osufan1984 thread starter macrumors newbie

    Feb 15, 2011
    I tried re-jailbreaking and it goes through fine then I left it on the complete screen for about 15 minutes and still no luck. I can get it into DFU mode when the power cord is plugged in, but not when it is USB only. Itunes recognizes it as an apple tv and goes through the restore process light normal but gets hung up at the very end. I am not too familiar with SSH but is there anything I could do using SSH to resolve this problem?
  4. earthmonster macrumors newbie

    Aug 5, 2010
    You won't be able to SSH into your AppleTV unless the jailbreak is successful and you've installed the software.

    Other than trying a fresh restore through iTunes, setting up the AppleTV on your TV, then trying a fresh Jailbreak I don't have much else to try.

    Try the iTunes restore without the power cord. If you follow my last post you'll get into DFU mode solely connected via the micro USB. After that hook it up to the TV, go through the start up, and then try the jailbreak again. Using GP you do need the power cord connected.

    Just keep trying I guess. Let it run until iTunes gives you an error.

Share This Page