Help with Boot Camp on Intel X25-M SSD

Discussion in 'MacBook Pro' started by axu539, Mar 10, 2011.

  1. axu539 macrumors 6502a

    Joined:
    Dec 31, 2010
    #1
    Hey guys, so I'm having a bit of trouble with my new 2011 MBP.

    I decided to go ahead and stick in my Optibay today, but since Macs can't boot DVDs from external drives, I need to install Windows first. The drive I'm using is an Intel X25-M G2 160 GB with a 100% clean install of Snow Leopard on it. I've already partitioned the drive using Boot Camp Assistant.

    This is where it gets weird. Once I insert the Windows install disc (it has worked before) and try to reboot to that, I just get the blinking folder with the question mark. If I try to boot back into OS X by holding option on startup, my Intel SSD sometimes fails to show up. I then try to eject the disc by holding the mouse button on startup, and the machine gets to the Apple, which changes into a circle with the slash through it. I can then get the machine to boot properly if I restart again 1-2 times.

    Now, if I pop my stock 128 GB SSD from Apple back into the machine, I can successfully boot to both OS X and the Windows install disc without a problem. But, I do not want Windows on this drive.

    Clearly, there seems to be an issue with the Intel drive. I have done permissions repair, I have reset the PRAM. Does anyone have any other ideas as to how to get this to work?
     
  2. axu539 thread starter macrumors 6502a

    Joined:
    Dec 31, 2010
    #2
    UPDATE: I am doing a fresh install (again) of Snow Leopard on the drive, as I simply can't think of anything else. Hopefully this fixes the issue, but something tells me it won't..
     
  3. chops42257 macrumors newbie

    Joined:
    Jan 13, 2008
    Location:
    Japan
    #3
    I am having the same exact issue. Have tried PRAM reset, set firmware password, then unset it, used rEFIt ... all of it not working

    similar symptoms when I try to boot on non-Mac bootable CD/DVD
     
  4. axu539 thread starter macrumors 6502a

    Joined:
    Dec 31, 2010
    #4
    After several hours of trying to get it to work last night, I gave up. My guess is that I am seeing some compatibility issues between the Intel SSD and the new MBP, and only some sort of firmware update can fix that. In the meantime, I'll just live without Boot Camp, since I really just wanted it to game.. I might test out Boot Camp on one of my other platter-based HDDs though, but I'm not sure I want to, since the only reason I really wanted to attempt Windows this time around was that I could game off of an SSD.
     
  5. Nightkrawler macrumors regular

    Joined:
    Sep 4, 2006
    Location:
    Vienna, Austria
    #5
  6. axu539 thread starter macrumors 6502a

    Joined:
    Dec 31, 2010
    #6
  7. axu539 thread starter macrumors 6502a

    Joined:
    Dec 31, 2010
    #7
    Ok so I got it to work. I installed the SSD in another computer and used that to update the firmware. The MBP was then able to Install Windows onto the drive. It's working without a hitch, Windows rates my machine at 6.9 with the SSD in, and it's actually running very cool at idle (around 38 C). It would idle at 60 C in my last C2D MBP.
     
  8. GelatinousSlime macrumors newbie

    Joined:
    Mar 19, 2011
    #8
    Thankyou! I was in the exact same situation, and putting the X25-M into another machine and flashing the firmware to the latest version did the trick for me too. I never even thought the problem might be the SSD when it otherwise seemed to be working fine and the problem I was troubleshooting was a failure to boot from the superdrive.
     

Share This Page