Help with BootCamp 5

Discussion in 'Windows, Linux & Others on the Mac' started by timothycricket, Mar 15, 2013.

  1. timothycricket macrumors newbie

    Joined:
    Mar 15, 2013
    #1
    Hi folks, first post here hoping that one of you guys can help me in this predicament.

    I have a late 2011 Macbook Pro (MBP 8,1) which I have replaced the original superdrive with an SSD. In addition, I still have the working superdrive in a USB enclosure.

    As soon as 10.8.3 came out I decided that I wanted to go for installing Windows 8 on my computer, however after 6 hours I've ran into some major pit falls. First off, using rEFIt I can't even start the Setup CD. It goes straight to a black screen with a blinking cursor. I then tried using OS X's internal start up manager and when I selected the Setup CD it displayed the words "Press any key to boot from CD..." but then when I pressed the key it just froze with the cursor blinking. I waited a good half hour, but it never began the set up sequence.

    So I then began trying to install windows through a USB thumb drive, convinced my CD approach would not work (I tried 2 different CD, both burned on my mac) and instead created a bootable USB through Parallels and WintoFlash. For some reason Windows 7 USB/ISO creator would not recognize my flash drive, so I just settled for using a third party technology, however when I tried to boot from bootmgr.efi using rEFIt, it just said "Error: Unsupported while loading bootmgr.efi"

    Finally, I tried to create a bootable USB using Boot Camp's native software. I used the trick where I edited BootCamps info.plist and changed the settings accordingly, however it seems that the plist has been modified a bit with Bootcamp 5 and it no longer says "USBLoader but preUSBLoader? Instead of being greyed out, the option to create a drive from DVD doesn't even exist.

    Can anyone help me? With any of these 3 issues? I would love to just have Windows 8 running. I can offer any information if anything is unclear.
     
  2. w0lf macrumors 65816

    w0lf

    Joined:
    Feb 16, 2013
    Location:
    USA
    #2
    So you're trying to install without a CD/dvd drive?

    If that's not the case and you do have a windows 8 install dvd then you should probably just remove whatever failed partition you tried to make and let bootcamp do the whole process for you.

    If you are trying to install without a CD/dvd drive then you might consider trying the same thing I did when I installed win8. I have a 2010 macbook pro that I have replaced the superdrive with a SSD just like you.

    One thing I'll note right off the bat is that you don't need an efi boot manager to install windows without bootcamp and unless you're constantly switching between the two OS it gets really annoying if you don't uninstall it.

    http://blog.laaz.org/tech/2012/04/24/installing-windows-7-on-macbook-pro-without-superdrive/

    Basically in super simple terms, use virtual box or another virtualization software to set up a windows partition so it's ready to boot and install windows then copy all the install files to that partition and boot from it.

    Hope it works for you and good luck.
     
  3. zoranx7 macrumors newbie

    Joined:
    Jul 3, 2011
    #3
    To re-instate the create usb install option in the bootcamp installer, you are correct when you say editing the plist does not work in bootcamp 5.0 as it did previously in bootcamp 4.0.
    Instead under the preusb support list insert, in correct numerical order; the model identifier for your macbook eg, 8,3 etc. close plist and hey presto when you open bootcamp assistant the create usb option will now be there. It really is that simple.
    However whether; once you have created the install usb, bootcamp will then continue to install windows is another matter entirely.
    My Macbook Pro late 2011 model identifier 8,3, will not. Bootcamp keeps asking for a system disk.
    Any help would be gladly welcomed.
     
  4. seangibbz macrumors newbie

    Joined:
    Nov 22, 2013
    #4
    I've had a similar issue. I wanted to create a USB from boot camp. I've tried adding my identifier in the numerical order (MacBookPro8,2). However, I get the "Boot Camp Assistant quit unexpectedly." error whenever I try to start Boot Camp after modifying the info.plist file.
     
  5. xcodeSyn macrumors 6502a

    Joined:
    Nov 25, 2012
    #5
    Do you have Mavericks (10.9) on your Mac? If you do, you need to know that Mavericks, unlike previous versions, doesn't allow any property list/configuration file to be used when it's been changed. See this thread to learn how to solve this problem. The OP of that thread even provides a video link on how to hack it.
     

Share This Page