Help with C&C First decade using xp in virtual box

Discussion in 'Mac and PC Games' started by Ash3r100, Apr 24, 2010.

  1. Ash3r100 macrumors newbie

    Joined:
    Jan 10, 2010
    Location:
    London
    #1
    Hi, ive been wanting to play the old c&c games on my MBP for ages and decided the best way to do it was to get first decade and run xp. im using virtual box because its free and i don't have to reboot. but i installed FD and it seems fine untill i run the games and i get various error messages

    For RA1 i get "Error - unable to allocate primary video buffer"

    For C&C i just get a blank error box

    TS asks me to insert the correct CD (which is in the machine)

    RA2 runs and i get sound but no video

    Quite frankly i think it was pointless buying this game!

    Any help would be greatly appreciated

    Thanks very much

    Asher
     
  2. Durandal02 macrumors member

    Joined:
    Apr 19, 2010
    #2
    Did you install the bootcamp drivers from your operating system disc that came with your mbp? The cd check might be a problem from running the game in a virtual machine; I've tried to install oblivion on a VM and securom gave me an error.
     
  3. AdamR01 macrumors 6502

    Joined:
    Feb 2, 2003
    #3
    Did you install the latest official patch (1.02) from EA? Or, even better install the unofficial 1.03 patch from here: http://www.cncsector.net/cnp/tfd

    This should fix most if not all of the issues you are having.
     
  4. Ash3r100 thread starter macrumors newbie

    Joined:
    Jan 10, 2010
    Location:
    London
    #4
    Thanks, i'll try both of these when ive got the time off work to try it.

    A
     

Share This Page