Help with Calendar Invitation Alerts - Odd Situation

Discussion in 'iPhone' started by javisan, Apr 17, 2012.

  1. javisan macrumors regular

    Dec 4, 2006
    Chicago, IL
    Hi everyone, I'll make it short and with facts of what I have done.

    The Facts:

    1. My wife has an iPhone 4S (iOS 5.1) and has her Gmail Email and Calendar setup as an exchange account in the "Mail, Contacts, Calendars" settings.
    2. I have an iPhone 4 (iOS 5.1) and also have my Gmail Email and Calendar setup as an exchange account in the "Mail, Contacts, Calendars" settings.
    3. We both use our Gmail email as the email account associated with our Apple ID.
    4. We both have Calendar Alerts fully activated on Notifications Center (same exact selections) and have also marked "New Invitation Alerts" as "On" in the "Mail, Contacts, Calendars" settings.
    5. We both have selected "Push" on the "Fetch New Data" Setting.
    6. We both have iCloud accounts but do not use the email nor the calendar functions of iCloud (we want to use Gmail).
    7. If we create our own events in our own Calendars and set a reminders (for example "at the time of the event", we both get the alerts/notifications normally.
    8. To summarize, I have gone item by item on both iPhones to make sure we have the same selections on every setting.

    The problem:

    If my wife creates an event on her phone and invites me (rememer gmail to gmail accounts with same configuations in both iPhones), I do not get any type of notification. The event will just show up on my iPhone Calendar greyed out until I accept it, but there is no type of notification (no popup notification and sound, no badge icon even though both are turned on in the settings of notification center an no pending invitations in the "Invitations" tab in the Calendar App).

    However, If I create an event in my iPhone 4 and invite my wife, she will instantly get a pop up notification, with the sound alert she chose and her Calendar will pop open once she presses the pop up and the "Invitations" tab of the Calendar app will show up for her to accept the event. Everything works fine with here iPhone! The problem seems to be related to my iPhone since if it was a Gmail problem, my wife would also be having the problem. Again, this problem is only when receiving invitations on my Calendar, because if I create my own event and set a reminder, it will function (alert) me as it should.

    I don't know what else to do! Any ideas of how I can resolve this?

  2. falterego macrumors 6502


    Dec 28, 2008
    Southern California
    I had the exact same issue. Two identical iPhone 4s phones setup with Gmail accounts as Exchange accounts with the same notification settings. I missed a doctor's appointment she had scheduled because I never got the alert for the invite or a notification when the event happened. I schedule everything in my calendars from car maintenance to doctors to airline flights and having no notification if my wife schedules an event for me could become quite a problem.

    On my phone I noticed the grayed out item in the calendar and double checked under the pending invites section (button in the lower right of the calendar) and it was not listed there. We've used the same process for as long as we've been together, and only in the past week has it stopped with the alerts. Previously we both had Android phones, then I upgraded a couple months before her. We ran just fine with both on iPhone 4s devices running 5.1 OS up until about a week ago. Nothing has changed that I could see causing this problem.

    I can add a note that when I receive an invite from a non-gmail address I get the alert, so it doesn't seem to be phone specific but rather email address specific.
  3. javisan thread starter macrumors regular

    Dec 4, 2006
    Chicago, IL
    Have you been able to solve this issue?

    I'm thinking of doing a restore since I thinks its an issue with my iPhone. I just tried it with a third person who has the Gmail Calendar setup as exchange and they also get all the invitation alerts and notifications as they should.

    Thanks for your input.
  4. zabalawi55, Jul 22, 2012
    Last edited: Jul 22, 2012

    zabalawi55 macrumors newbie

    Feb 29, 2012
    I solved it finally.


    i had same problem and i solved it out, i had gmail, hotmail, yahoo all accounts in my iPhone and that was the reason, i removed all of them and keept Gmail and i started getting a normal instantly pop up notification.

    i know its crazy to remove other emails but thats how i solved my problem.

    @ javisan
    If you look at your wife's phone you will find that she has only Gmail in her phone unlike us men we have 3 emails or maybe more.

  5. scaredpoet macrumors 604


    Apr 6, 2007

    That's not really solving the problem, because it should work even with multiple e-mail accounts. I have an iCloud account, a work Zimbra account set up as exchange, and a Gmail account set up as Exchange, and I can receive notifications fine.
  6. mikeheck2009, Aug 9, 2012
    Last edited: Aug 9, 2012

    mikeheck2009 macrumors newbie

    Aug 9, 2012
    Same issue, just started for me as well.

    I have just started having the issue of not getting alerts (badge or sound) on invites on my iPod Touch (2nd Gen). It was working fine for a long time, wondering what changed it. I have done a complete reset and restore as a new iPod and still "no go". I have a gmail account set up as Exchange as before. Others get my invites when I send them without issue. Invites do show on my calendar as grey (awaiting a reply) but I have no email or calendar alert when it comes in. - oh and after i did the last restore, i don't see the notification section under settings anymore either (it was there before even though the invites did not alert me). According to iTunes, the iPod is as up to date as it's gonna get.
    Only have the Gmail (as Exchange account) on the iPod.

    Any ideas?

  7. mikeheck2009 macrumors newbie

    Aug 9, 2012
    I found this searching Google help for exchange and my issue is resolved!

    I found this searching Google help for exchange and my issue is resolved!

    - To enable 'New events', sign in to your Google Calendar using the web browser on your phone or computer. Go to Calendar Settings > Calendars > Click on the Notifications for the calendar you want to sync. Under Email check 'New events' (and any of the other Invitation settings you want enabled e.g. changed events, cancelled events, event responses), and click Save.
  8. 1976Hoosiers macrumors newbie

    Dec 2, 2010
    Austin, TX
    Turn Fetch New Data to Push

    I couldn't figure out what was going on until I realized my Fetch New Data was turned off. Once this is turned on the push notifications should start to populate again. I never thought I would be so happy to see Google Calendar invites again :)

Share This Page