Help with changing language

Discussion in 'macOS' started by Smetty, Apr 18, 2011.

  1. Smetty macrumors newbie

    Joined:
    Apr 18, 2011
    #1
    Hello,

    I was editing a document with some Japanese and my mac got set to this language. I walked away from the computer and now it's only allowing me to type in Japanese when I try and log back in. Is there a hotkey combo that will allow me to toggle back to English?

    Thanks
     
  2. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #2
    私は日本の転換だと思う。私は日本の転換だと思う。私は本当にそう思います。
     
  3. davidlv, Apr 19, 2011
    Last edited: Apr 19, 2011

    davidlv macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #3
    Edit: After I typed the answer below, I found that this is actually a Catch 22-type of problem. You need to set "Show input method at log in" in the Accounts/Log-in Options in System Preferences, but you cannot do that until you are loged in ???.
    Anyone know how to get around this? May have to boot up from the System DVD and change the password. http://support.apple.com/kb/HT1274 "Resetting the original administrator account password"
    1. At log in, the language used is as set in the System Preferences, Language and Text, Language -- the system uses the language on the top of the list on the left side. I don't know what t do if you have the system set to show the log in screen. Can you use the mouse and the icon flag/hiragana icon up to the right on the menu bar to select the American flag (English)?
    2. On a Japanese keyboard, there is an English and Japanese key on the right and left sides of the space bar. I ssume you have and American or British keyboard, so that doesn't help.
    Normally, the hot key to set the language used is Command+Space, but that is set to pop up Spotlight, so go to the System Preferences, Keyboard, Keyboard Shortcuts, Spotlight, and uncheck both boxes.
    You can also mouse up to the top right, (next to the sound indicator) and click on the English flag/Hiragana (あ) and select the language there (depends on what is set in the Language and Text, Input sources dialog box. Set two, English and Kotoeri, switch between them manually using the flag/hiragana icon, then try using the Command+Space hot key. Should work alright now. :cool:
    You may have to search the Apple database for more info on switching to English at the log-in screen.:confused:
    http://support.apple.com/kb/HT4099
    http://support.apple.com/kb/HT4102
    Which say: Use the System Preferences from the Apple Menu, follow the instructions as shown above.
     

Share This Page